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Safety and Precautions 
To keep the kSA SpectR system operational and to keep those who use it from harm, please 
heed the cautions and warnings noted below. 

 

Symbols and Labels 
When you see the symbols or labels below, be sure to read them carefully to determine the 
potential safety issue. 

 Note 

This list includes the potential cautions and/or warnings for multiple k-Space products. Some of these 
may not apply to your installation or testing environment. 

 

Sign Potential Safety Concern 

WARNING 

 

Indicates the possibility of: 
 Minor injury 
 Damage to the system or its accessories 
 Problems relating to the quality of the process 

DANGER 

 

Indicates the possibility of: 
 Very serious injury 
 Fatality 
 Considerable damage to property 

EYE PROTECTION 

 

Indicates that you should wear protective laser goggles/glasses. 

LASER RADIATION 

 

Indicates that there is potential for laser exposure. 
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Sign Potential Safety Concern 

HEAVY OBJECT 

 

Indicates that the object is heavy and possibly awkward for one person 
to lift without assistance. Multiple people should assist in the lifting of 
this object. 

BURN HAZARD 

 

Indicates that hot surfaces pose a risk for burns when a compartment 
is opened. 

Cautions and Warnings 
It is important that you take the following precautions when working with these components 
of your kSA SpectR system. 

Sign Precautions 

ALIGNMENT LASER 

   

 Never look directly at the focused beam from the detector, and always 
use laser goggles when aligning the system. The alignment laser used 
in the system is a Class IIIA laser. (Only Class I lasers present no 
concern for eye injuries.) 

 Always set the laser interlock to OFF when the laser is not in use. 

DIODE LASER 

 

When the system is not in use for extended periods of time, shut down 
the laser. Laser diodes have a finite lifetime, and proper care will ensure 
that it lasts as long as possible. 

DIODE LASER 
CONFIGURATION 

 

The diode laser controller supplied with your complete system has been 
pre-configured with the correct operating parameters for that particular 
laser, and they will protect that laser from damage. Do not change these 
operating parameters. Refer to the diode controller configuration sheet 
supplied with the system for the correct settings. 

DIODE LASER POWER 
AND CONTROL 

 

Never disconnect or connect the laser diode control cable while the 
controller is powered up—this will destroy the laser. Diode lasers are 
extremely electrostatically sensitive and are not protected against static 
discharge when disconnected from the controller unless specific 
precautions are taken to short the laser power leads. 
Fiber-coupled laser packages have a shorting switch to protect the laser 
when it’s not connected to the controller. Be sure to use this switch when 
disconnecting the cables. 

ELECTRONIC BOARDS 

 

Whenever handling any electronic boards, ensure that you are properly 
grounded and that you do not touch the contact pads along the bottom of 
the board. 

FIBER OPTIC CABLES 

 

 Optical fibers are fragile. Do not kink or allow them to be snagged on 
sharp edges. 

 Do not bend the cables to a radius of < 13 cm. 
 Do not sharply bend or kink armored fiber optic cables. 
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Sign Precautions 
I/O INTERFACE 

 

Before making connections, refer to the Rack Mount Controller 
Installation information for a complete functional description of each pin 
in the BNC and DB-15 I/O connectors on the rack controller. 

INTERNATIONAL 
INSTALLATIONS 

 

Outside of North America, please be sure to check that the power setting 
on the back of the computer matches the supplied power in your region. 

LAMP 

 

 Never stare into the lamp output. The lamp output contains focused 
infrared radiation, and long-term exposure to the lamp output can 
cause serious damage to your eyes. 

 Do not place flammable materials on or near the lamp housing at any 
time. Always allow time for the lamp and all surfaces surrounding the 
bulb to cool before attempting to replace the bulb. 

OPTICS 

 

 Do not allow debris to fall into the optical port on detector heads. 
 Do not open optical head cases in dirty environments. 
 Do not touch internal optical surfaces inside the optical head. 

POWER 

 

 Use a surge protector for all AC power cable connections. 
 Connect all cables before plugging in the system. Ensure that the unit 

is plugged in to a properly grounded outlet.  
 The system uses a high current supply to power the lamp, so never 

connect or disconnect the lamp power cable or service the lamp in 
any manner unless the system power is OFF. 

 Always unplug the rack controller when replacing or servicing the 
lamp. 

SERVICE 

 

Do not service the unit beyond the procedures described in this 
document. None of the parts in the rack controller should be serviced by 
the user; contact kSA to service those. 

SMA CONNECTOR ENDS 

 

Do not allow SMA connector ends of optical cables to touch dirt or grease. 

VENTILATION 

 

System components should be mounted in well-ventilated areas. Ensure 
that there is adequate airflow above the rack controller (intake) and to 
the fan side (exhaust) of the rack controller. Also ensure that there are no 
obstructions around the lamp housing air intake fan or the exhaust vents. 

WATER AND MOISTURE 

 

Do not use the system near water or in any area where excessive 
moisture or condensation may come in contact with system components. 
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1 kSA SpectR Overview 
The kSA SpectR system is an non-contact, non-invasive, optically based, real-time metrology 
instrument. This powerful in situ tool monitors and controls film deposition processes. The 
primary function of the kSA SpectR is to monitor the spectral reflectivity of a film stack during 
deposition. 

The kSA SpectR system consists of one or more spectrometers, a broadband light source with 
an integrated shutter, and the associated electronics, all contained in a 3U rack. k-Space can 
configure your kSA SpectR with a spectrometer that covers the visible wavelength range, the 
near infrared (NIR) range, or both ranges (if you choose a dual-spectrometer system). 

The integrated shutter allows the system to remove any stray light that would otherwise 
compromise the reflectivity measurement. This is especially important with NIR units, and/or 
with units intended for use during high-temperature growth. In both cases, blackbody 
radiation can introduce a significant background signal. The light source and spectrometer 
are fiber-coupled to the optical assembly, which is mounted on the deposition chamber, as 
described in the Optical Assembly section. 

The system contains a data acquisition (DAQ) board that controls the light source/shutter and 
provides user-assignable digital and analog I/O. In addition, the system contains a 
microprocessor-based rotation monitor that synchronizes the operation of the light source’s 
integrated shutter with the reflectivity measurement. This can also be used to sync the 
reflectivity measurement with the substrate rotation using a home pulse provided by the 
deposition chamber. This can be beneficial if the substrate suffers from wobble, which can 
lead to significant variations in the measured reflectivity during rotation. By synchronizing 
with the rotation, you can set up the measurements to occur only at a point where the optics 
are perfectly normal to the sample, ensuring the most accurate reflectivity value possible.  

The front panel of the kSA SpectR rack (shown below) includes the main power switch and 
controls for the laser, light source, and shutter. 
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The following block diagram depicts the components in the kSA SpectR rack and the flow of 
data and information. 

 

 

The kSA SpectR uses the following equation to calculate the absolute reflectivity. 

𝑹𝑹𝒂𝒂𝒂𝒂𝒂𝒂(𝝀𝝀) =
𝑰𝑰𝒐𝒐𝒐𝒐𝒐𝒐𝒐𝒐(𝝀𝝀) − 𝑰𝑰𝒄𝒄𝒄𝒄𝒄𝒄𝒄𝒄𝒄𝒄𝒄𝒄(𝝀𝝀)

𝑰𝑰𝒓𝒓𝒓𝒓𝒓𝒓(𝝀𝝀)  𝑹𝑹𝒓𝒓𝒓𝒓𝒓𝒓(𝝀𝝀) 

 

Variable Description 

Rabs(λ) Spectral reflectivity of the sample in an absolute sense 

Rref(λ) Corresponding quantity for the reference sample used to calibrate the system 

Iopen λ) Raw spectral intensity measured with the shutter open 

Iclosed(λ) Raw spectral intensity measured with the shutter closed 

Iref(λ) Raw spectral intensity measured using the reference sample 

 Optical Assembly 
The image below depicts a typical kSA SpectR single-port, NIR optical assembly mounted on a 
4.5” CF viewport. Note that both the broadband light source and the NIR spectrometer are 
fiber-coupled. Also note that this system incorporates an x-y translation stage for precise 
alignment to a specific location on the sample. 
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The schematic below provides a schematic of the kSA SpectR NIR optical assembly. 
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The kSA SpectR NIR optical assembly shown below includes two flexures that allow you to 
adjust the position and tilt of the assembly. 

 

 A 1” flexure allows for precise alignment of the spectrometer’s fiber feed relative to the 
light source. This has a pair of adjustment screws and corresponding locking screws (the 
locking screws have the shorter heads). These screws require a 5/64” (2 mm) hex key. 
Note that k-Space engineers configure these during instrument commissioning, and they 
should not need to be adjusted under normal circumstances. 

 

 

The chamber mounting hardware provides several degrees of freedom to enable precise 
adjustment of the optics relative to the sample. 

 A 2” flexure allows for adjustment of the overall tip and tilt of the assembly. Like the 1” 
flexure, this has a pair of adjustment screws and corresponding locking screws The 
adjustment and locking screws require a 5/64” (2 mm) hex key. The flexures provide up 
to 6° of angular motion for each axis. 

 

Lock Screw 

Adjuster Screw 
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 Important! 
This adjustment is critical to ensure that the optics assembly is precisely normal to the sample. 
See How to Align the Optical Assembly for details on the alignment procedure. 

 

In addition to the locking screws on the adjuster, the system uses a pair of foil locks to 
secure the 2” flexure position so that it does not drift over time after alignment. 

 

1.1.1 Light source neutral density filter option 

When working with highly reflective samples, such as distributed Bragg reflectors (DBRs), it is 
sometimes necessary to reduce the output of the light source to prevent saturation of the 
spectrometer. This is typically required for visible spectrometers only, as they are inherently 
much more sensitive than NIR units. For that reason, the internal light source in the 
kSA SpectR rack has a built-in holder for 1” filters. If necessary, k-Space will provide an 
appropriate neutral density (ND) filter. You can lock the filter holder in place using a 1.5 mm 
hex key to tighten the set screw. 

 
Locking Screw (1.5 mm hex key) 

Filter Holder 

Adjuster Screw 

Lock Screw 

Lock Screw 

Lock Screw 
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1.1.2 Translation stage option 

k-Space offers an optional precision x-y stage that provides translation for the optical 
assembly. This allows you to precisely position the measurement spot at a specific location on 
the sample. 

1.1.3 Angled nipple option 

Because the kSA SpectR is intended to measure the absolute spectral reflectivity of a sample, 
for single-port (i.e., normal incidence) systems, it is critical that it does not detect any light 
reflected off the deposition chamber’s viewport, as this could compromise the reflectivity 
measurement. To address this, the kSA SpectR uses an angled viewport, which directs the 
reflection of the incident light at an angle so that the detector cannot see it. 

For systems with a heated viewport, the alternative solution is to use the angled 
nipple/wedge adapter solution depicted below. The angled nipple places the heated viewport 
at the desired angle, and the wedge adapter allows the optical assembly to remain at normal 
incidence to the sample. Because of the angles involved, it results in a somewhat reduced 
clear aperture. 

 

1.1.4 Dual-range spectrometer option 

If you need a broader spectral range than a single spectrometer can provide, k-Space offers 
dual-range spectrometer systems. The example system below uses sapphire beam splitters to 
preserve spectral neutrality so that either feed can use a visible or NIR spectrometer. 

Wedge Adapter 

Viewport 
Heated Viewport 

Angled Nipple 

X-Y Stage 
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1.1.5 Two port option 

k-Space can configure the optics in a two-port arrangement, in which the light source and 
detector are specularly opposed at an off-normal incidence angle. For these systems,  
polarization effects must be considered to obtain accurate reflectivity results. There are two 
possible polarization states. 

 p (i.e., TM): The polarization vector is parallel to the plane of incidence and reflection. 
 s (i.e., TE): The polarization vector is perpendicular to the plane of incidence and 

reflection (from the German term senkrecht). 
 

 Note 

For single-port (normal incidence) systems, there is no distinction between the two states, so the 
polarization state selection is immaterial. 

 

The image below illustrates the definition of the s and p polarization states. 

 

 Broadband Light Source 
The kSA SpectR software application allows you to control the broadband light source 
remotely through the software. To enable this feature, follow the steps below. 

1. In the Single-wafer Spectral Reflectivity Acquisition window, click the Advanced button to 
open the Advanced Acquisition Options dialog. 

2. Click the Reflectivity Shutter and Light Configuration tab. 
3. Check the Enable light control box, and then select the digital output channel used to 

control this feature. 

4. Click OK to save this setting. The Light Source Control  button on the toolbar should 
now be enabled. When you click that button, the kSA SpectR application will toggle the 
light source on/off. 
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 Spectrometer 
The kSA SpectR is based on one or more sensitive solid-state spectrometers. Depending on 
the purpose, k-Space offers NIR units with a wavelength range of approximately 900-1700 nm 
and visible units with a range of approximately 350-1100 nm. The kSA SpectR software 
application enables you to view the data in a Live Spectrometer window as they are being 
acquired. 

 To open a Live Spectrometer window, select the desired spectrometer from the View 

menu or click the Live Spectrometer  button on the toolbar. 

The screenshot below shows a typical live spectrometer window in the kSA SpectR 
application. The status bar along the bottom of the window displays the minimum and 
maximum spectral intensity, the integration time, the electronics (i.e., rack) temperature, the 
sensor temperature, and the flat field correction (FFC) status. The FFC is a correction curve 
that serves to flatten the spectrometer’s inherent wavelength-dependent response. 
 

 Note 

Do not use the FFC in the kSA SpectR application, as the reference spectrum fulfills its function. 

 

To enable/disable the spectrometer’s external trigger, click the External Trigger  button 
on the toolbar along the top of the Live Spectrometer window. 

To adjust the settings for the spectrometer, right-click the Live Spectrometer window and 
select Properties to open the Spectrometer Properties dialog. This dialog includes several 
tabbed pages, each with different parameters and options that apply to the selected 
spectrometer. 
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 k-Space’s Customer Focus 
k-Space has always made customer needs a primary focus. As technology evolves, k-Space 
continues to update and enhance all of our products with new features and improved 
software. Many of the enhancements and features we have implemented are a direct result 
of suggestions from our customers. We highly encourage customer feedback and suggestions 
for any of our products. We listen to our customers and constantly look for ways to ensure 
that our instruments provide expert metrology solutions and simplify their work. 

k-Space takes pride in giving our customers excellent technical support — the engineers who 
design and build the tools and software routinely respond directly to customers with 
personalized solutions. Please contact us with any suggestions, comments, or questions. 

 Finding Information in This User Guide 
 The How-To Guides chapter includes a collection of the most commonly used kSA SpectR 

procedures to make it easy for you to find important processes. 
 Throughout this manual, there are numerous instances of blue, underlined text that link 

to related information elsewhere in the manual. Click these links to jump to the related 
content, and then press ALT+   on your keyboard to return to the previous location. 

 To search for content within this user manual, press CTRL+F or click the  button on the 
Acrobat Reader toolbar. When the Find dialog opens in the upper-right corner of the 
window, enter a search term, and then press the ENTER key on your keyboard to initiate 
the search. As you enter the search term, Acrobat Reader lists potential matches, so if 
your term is on the list, you can select it from that list. 
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2 Exploring the kSA SpectR Software 
Application 
The kSA SpectR uses proprietary software to collect, analyze, and store data. k-Space uses a 
common software user interface (UI) for many of its core products. With the consistent look 
and feel across products, customers with multiple k-Space products are already accustomed 
to the interface and can start using the software right away. For those who are not familiar 
with k-Space software, this chapter describes various features of the UI. 

 Sentinel Key 
All kSA SpectR systems require a dedicated Sentinel key to access the software. The Sentinel 
key is a USB firmware adapter that contains your kSA SpectR software license. It provides 
access to all data acquisition and analysis features included with your license, activates any 
purchased plug-in options, and protects the kSA SpectR software from illegal distribution. 

Your kSA SpectR system includes a custom-fitted box (similar to the one in the following 
image) that contains your Sentinel keys and software (on a USB drive).  

 The Sentinel key with a red tag provides access to all data acquisition and analysis 
features included with your software license. 

 The Sentinel key with a blue tag provides access to the analysis-only software (AOS) 
features. The AOS version of the application includes all of the analysis capabilities but 
none of the acquisition capabilities. 

 The kSA software drive (red or black USB drive) contains the software installation files, 
registration file, and other important files. 
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To run the kSA SpectR application, insert the Sentinel key into an available USB port on the 
kSA SpectR computer. 

 Software User Interface 
To open the kSA SpectR application, double-click the kSA SpectR icon on your Windows 
desktop, or select SpectR > SpectR from the Windows Start menu. 

Like other Windows applications, the kSA SpectR application uses menus and toolbars to 
provide access to various windows, dialogs, and commands. The menus, commands, and 
toolbar buttons that are available at any given time depend on the active window in the 
application. The title bar at the top of the kSA SpectR application displays the name of the 
active window. 

 

2.2.1 Menus and Menu Commands 

The following menus are available in the kSA software UI. 
 

Menu Available Actions 

File Open, close, save, export, and print data; exit the kSA application. 

Edit Undo the last action, copy the contents of the active window, and access the 
applicable Properties dialog. 

View Open a Live Spectrometer window; zoom in/out in the active window. If a 
data acquisition window is open, it also includes available real-time charts. 

Analysis (Available only when the active window is a data file) Select available post-
acquisition analysis plots. These are generally not used for the kSA SpectR. 

Acquire Select available data acquisition modes. 

 
 

 
 

 
 

 
 

 
 

 
 

kSA software drive 

Sentinel key 

AOS Sentinel key 
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Menu Available Actions 

Options Specify options for the kSA system and activity and data logging; save or recall 
all software settings. 

Window Arrange the open plot windows; quickly switch between open windows. 

Help View version and copyright information for the kSA software; view contact 
information for k-Space Associates, Inc. 

2.2.2 Main Toolbar 

The buttons on the main toolbar of kSA applications give you quick access to many of the 
options that are available on the various menus. The toolbar buttons are grouped together 
based on function. 

Standard toolbar 

These buttons have the same functionality as in other Windows applications. 

 

Toolbar Button Description 

Open file 

 

Opens a dialog for you to browse to and select a data file to open. 

Save file  

 

Saves the data in the active window to a file. 

Copy content 

 

Copies the selected data to the Windows clipboard, making it available to 
paste into documents in other applications. 

Print file 

 

Prints the data in the active window. 

Zoom in/out 

 

Zooms in and out in the active window. 

kSA SpectR toolbar 

These buttons provide access to hardware features that are controlled through the software. 

 

Toolbar Button Description 

Live Spectrometer 

 

Opens a Live Spectrometer window , where you can view data in real-time as 
they are being acquired. 



Exploring the kSA SpectR Software Application 
 

kSA SpectR User Manual 14 

Toolbar Button Description 

Home Pulse 
Positioning 

 

(N/A for the kSA SpectR) 

Dark Background 

 

Opens the Dark Background Acquisition window to acquire background data 
in the absence of light. The application then subtracts that data from the live 
spectra to reduce noise. 

Reference 

 

Opens the Reference Acquisition window to acquire reference data, based on 
a specified number of samples, to normalize the acquired spectrum. 

Single-wafer 
Spectral Reflectivity 

 

Opens the Single-wafer Spectral Reflectivity Acquisition window to measure 
reflectivity, film thickness / growth rate, and optical constants (n, k). 

Software User 
Mode 

 

Opens the Select User Mode dialog, where you can select the user mode level 
for the kSA SpectR application. 

User Manual 

 

Opens a PDF of this user manual. 

Light Source Control 

 

Toggles the light source off and on. 

2.2.3 Plot Window Toolbars 

The Live Spectrometer window and many .kdt plot windows include their own toolbars along 
the top of the plot window. 

Live Spectrometer toolbar 

The Live Spectrometer toolbar is available within Live Spectrometer windows. These buttons 
control the spectrometer as it acquires data. 

 

Toolbar Button Description 

Resume 

 

Resumes a live display of the spectrometer output that has been paused. 

Pause 

 

Pauses the live display of the spectrometer output. 

Refresh 

 

Updates the display in the Live Spectrometer window to show the current 
data. 
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Toolbar Button Description 

Snapshot 

 

Captures a screenshot of the current spectrum and saves it to a file. 

Properties 

 

Opens the Spectrometer Properties dialog, where you can change parameters 
for the selected spectrometer. 

Plot Properties 

 

Opens the Plot Properties dialog, where you can change parameters for the 
Live Video window display. 

kdt toolbar 

The kdt toolbar is available within kdt plot windows that display spectral data. These buttons 
control the playback of the plotted data. 

 

Toolbar Button Description 

Rewind 

 

Returns to the first frame of the data file. 

Reverse 

 

Moves back one frame at a time. 

Play 

 

Plays the data in the file. 

Pause 

 

Pauses the display of data in the file. 

Advance 

 

Advances one frame at a time. 

Go to end 

 

Advances to the last frame of the data file. 

Loop 

 

Automatically replays the data from the beginning after it reaches the last frame. 

Snapshot 

 

Captures a screen shot of the current frame of the .kdt data file and displays the 
snapshot in a new data window. 

2.2.4 Status Bars 

The kSA SpectR application includes a status bar along the bottom of the main application 
window to display information about the current data acquisition or analysis. 
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In addition, the Live Spectrometer window includes a status bar that provides up-to-date 
information about the selected spectrometer throughout the acquisition. This information 
includes the minimum and maximum spectra intensity values; spectrometer integration time; 
rack, sensor, and optic temperatures; and flat field correction status. 

 

Many of the real-time charts also include a status bar along the bottom of the plot window to 
display relevant information about the acquired data. 

 

2.2.5 Right-click context menus 

When you right-click the a Live Spectrometer window or a data plot window, the application 
displays a context menu that includes commands for manipulating the display in the window. 
The commands at the top of the Live Spectrometer right-click menu are the same as the 
commands on the Live Spectrometer toolbar. 
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Data or Analysis plot window 

 

Live Spectrometer window 

 
 

Menu Command Description 

Copy Copies the plotted data to the Windows clipboard, making it available to 
paste into documents in other applications. 

Properties Opens the Spectrometer Properties dialog, where you can change parameters 
for the selected spectrometer. 

View Output Pane Toggles a data pane below the plot to display the output. 

Goto  Opens the Go To Frame dialog, where you can specify the exact frame to 
jump to — the exact frame number or the frame at a specific elapsed time. 

 
Zoom In/Zoom Out Zooms in on/out of the plotted data. 

Set X Min/Max 
Set Y Min/Max 

Sets the minimum/maximum value for the X/Y axis to the X/Y value of the 
current cursor position. 
In other words, when you right-click a position on the plot and select Set X 
Min, that cursor position becomes the lowest X value on the plot. The 
application removes all data left of that position and spreads the remaining 
data to fill the plot window. 

Auto X/Y Range Resets the minimum and maximum X/Y values to the default values. 

Set Y Min Offset Sets the minimum Y value as an offset from the maximum Y value, rather than 
using an absolute value. 
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3 How-To Guides 
This chapter provides step-by-step instructions for some of the most commonly used 
features and applications of the kSA SpectR system. 

 Aligning the optical assembly 
 Acquiring a dark background 
 Acquiring a reference spectrum 
 Acquiring spectral reflectivity data 
 Performing a reflectivity fit 
 Setting the spectra phase delay 
 Calibrating the spectrometer 

 How to Align the Optical Assembly 
This alignment procedure is best done with a stationary (i.e., non-rotating) wafer. 

1. Open a Live Spectrometer window by selecting the applicable spectrometer from the 

View menu or by clicking the  button on the toolbar. 
2. Right-click the Live Spectrometer window, select Properties, and click the Spectrometer 

tab. 
3. Use the slider to set the desired integration time, and verify that the External trigger 

checkbox is cleared to ensure that the spectrometer is in free-running mode. 
4. Click the Averaging tab and ensure that the averaging is set to 1. 
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5. Select Acquire > Peak Intensity Alignment Acquisition. 
6. In the Peak Intensity Alignment Acquisition window, select the desired spectrometer 

from the Peak intensity drop-down list. 
7. Click the Advanced button, and then click the Delay tab. 
8. Select Between data points from the drop-down list in the Delay type field, and then 

choose the No delay option below that. 
9. Choose the amount of data to save — Continuous (no data saved) to view the data 

without saving them, or Duration to acquire data for a specific length of time. 
10. Select View > Real-time Peak Intensity over time to view that real-time chart (RTC) during 

acquisition. Note that if your system has multiple spectrometers, the application will 
open a separate chart for each one. 

 

11. Click Start when you are ready to start the acquisition. Observe the RTC and adjust the 
optics such that the intensity is maximized (see Optical Assembly for details). 

 

 Notes 

 After you complete the alignment, you may need to adjust the Processing intensity floor setting 
on the Spectrometer Configuration > Spectral Reflectivity Configuration tab to account for any 
resulting changes in intensity. 

 For best results, you should acquire a new reference spectrum any time you adjust the optics or 
load a new sample. 

 How to Acquire a Dark Background 
In many cases, the spectra acquired during data acquisition contain stray signals (aka, noise) 
that distort the actual spectra of the sample. To account for this noise, the kSA SpectR 
includes the Dark Background Acquisition mode, which acquires data in the absence of light 
to represent the spectral noise. The application then subtracts the noise from the live spectra 
during data acquisition, resulting in clean spectra that are free of noise. 
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 Important! 
You will need to acquire a dark background the first time you run the kSA SpectR and on a regular 
basis — e.g., before each temperature acquisition, once a week, once a day, etc. 

3.2.1 Specifying integration times 

A spectrometer’s integration time is the length of time the detector collects a signal before it 
digitizes and sends the signal to the application for processing. The integration time plays an 
important role in reducing noise in the incoming spectrometer signals. 

To remove background noise from a live spectra, you must acquire the live spectra at an 
integration time for which you have a corresponding dark background spectrum. To ensure 
this, you can acquire dark background data for a range of integration times. That range 
should include the integration times that you will use for data acquisition. 

To define the range, use the Min, Max, and Step fields in the Dark Background Acquisition 
window. For example, if you acquire a dark background using the values shown in the image 
below, the application will acquire background data at the 10, 20, 30, …, 190, 200 ms 
integration times only and then save the data in a dark background .kdt file. 

 

To remove background noise from the live spectra during data acquisition, check the Subtract 
Hardware Background Time box on the Spectrometer Properties > Spectrometer tab, and 
then in the Set Integration Time field, specify the integration time to use during data 
acquisition. The value in this field must be one of the times included in the dark background 
data. Using the example above, the spectrometer integration time of 200 ms is valid, as 
background data were acquired at that integration time. 
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The status bar in the Live Spectrometer window displays the spectrometer integration time. 

 

3.2.2 Acquiring dark background spectra 

 Important! 
You must eliminate all light from the chamber when you acquire a dark background. The best way 
to ensure this is by removing the fiber from the spectrometer’s input SMA fitting (labeled 
SPECTROMETER) on the back of the electronics rack and tightly covering the input with the black 
plastic cap provided. 

 
 

Follow these steps to acquire dark background data. 

1. Allow the electronics rack sufficient time to reach thermal equilibrium before acquiring a 
dark background. The noise is caused by thermally generated charge carriers in the 
spectrometer’s sensor material and is thus strongly temperature dependent. 

2. Select the applicable spectrometer from the View menu or click the  button on the 
toolbar to open a Live Spectrometer window. Dark background data are spectrometer-
specific, so you must acquire the dark background using the same spectrometer you will 
use for data acquisition. 

3. Note the sensor temperature, and verify that the electronics rack has had sufficient time 
to reach thermal equilibrium. 

4. Right-click the Live Spectrometer window, select Properties, click the Spectrometer tab, 
and verify that the External trigger box is cleared to ensure that the spectrometer is in 
free-running mode. 

5. Select Acquire > Dark Background or click the  button on the toolbar to open the 
Dark Background Acquisition window, and select the applicable spectrometer in the 
Spectra Source field. 

6. Verify that the Samples per datapoint, and Min / Max / Step settings are correct.  
7. Click the Start button to begin the acquisition. After the acquisition is complete, the 

application will automatically apply the new dark background to subsequent acquired 
spectra. 
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8. Verify that the desired range of integration times is available by right-clicking the Live 
Spectrometer window, selecting the Properties dialog, and clicking the Spectrometer tab. 
The spectrometer should be in the 0 ± 100 counts range at every available integration 
time. 

9. Reconnect the fiber to the spectrometer input on the back of the electronics rack. 
 

 Note 

If the system has multiple spectrometers, repeat this procedure for each one. 

 How to Acquire a Reference Spectrum 
The kSA SpectR uses reference data (spectrum of the lamp intensity) to normalize the spectra 
acquired during data acquisition. This provides a flatter baseline and results in a more 
accurate extrema wavelength determination. The application saves the reference data in a 
reference .bsrf file. 
 

 Important! 
It is critical that you take the reference at the same lamp power that you will use during data 
acquisition, as the shape of the lamp’s output spectrum is strongly power-dependent. 

 

Follow the procedure below to obtain a reference spectrum. 

1. Select the applicable spectrometer from the View menu or click the  button on the 
toolbar. 

2. Right-click the Live Spectrometer window, select Properties, and click the Spectrometer 
tab. 

3. Use the slider to set the desired integration time (in ms), and verify that the External 
trigger checkbox is cleared to ensure that the spectrometer is in free-running mode. 

 

 Note 

The integration time for the reference spectrum must be the same as the integration time you 
will use during spectral reflectivity data acquisition. 

 
 

4. Select Acquire > Reference (Single Wafer) to open the Reference (Single Wafer) 
Acquisition window. 
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5. Select the desired spectrometer from the Spectra source drop-down list. 
6. Enter the desired name for the data file in the Archive Name field, and specify the 

number of Samples to collect. 
7. In the Processing intensity floor field, enter the minimum value of the peak intensity that 

a spectrum must possess to be considered valid. 
8. Check the Auto-select reference checkbox to use the new reference after it is acquired. 
9. Click Start when you are ready to begin the acquisition. 

 How to Acquire Spectral Reflectivity Data 
Follow the procedure below to acquire spectral reflectivity data. 

1. Select the applicable spectrometer from the View menu or click the  button on the 
toolbar to open the Live Spectrometer window. 

2. Right-click on the Live Spectrometer window, select Properties, and click the 
Spectrometer tab. 

3. Use the slider to set the desired integration time. The selected integration time must 
match the integration time used to acquire the reference spectrum. 

4. If you are using the light source’s integrated shutter, confirm that one of the following 
conditions is met to prevent the shutter from attempting to open and close too quickly. 
 The spectrometers are externally triggered. 
 The acquisition delay time is at least 2.0 seconds. 
 The spectrometer integration time is at least 2.0 seconds. 

5. Select Acquire > Single-wafer Spectral Reflectivity or click the  button on the toolbar 
to open the Single-wafer Spectral Reflectivity Acquisition window. 

6. Select the applicable spectrometer from the Spectral Reflectivity drop-down list. 
7. Click the Config button to open the Spectrometer Configuration Options dialog and 

specify settings on each applicable tabbed page, and then click OK to apply the settings. 
8. If your kSA SpectR has multiple spectrometers, repeat steps 1-6 for each additional 

spectrometer. 
9. In the Run name field, enter the name of the file in which the save the acquired data. 
10. Choose the amount of data to save — Continuous (no data saved) to view the data 

without saving, or Duration to acquire the data for a specific length of time. 
11. Click Start to begin the acquisition. 
12. Select the desired RTCs from the View menu. The following RTCs are available for Single-

wafer Spectral Reflectivity acquisitions. 
 Overall Reflectivity 
 Real-time Stats/Real-time Stats 2 
 Spectra/Spectra 1/Spectra 2 
 Real-time Fabry-Perot 
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 How to Perform a Reflectivity Fit 
The kSA SpectR uses a sophisticated Virtual Interface algorithm that was originally developed 
at Sandia National Laboratories to determine the growth rate, layer thickness, and optical 
constants (n, k) from the measured reflectivity of a multi-layer structure in real-time. This 
algorithm utilizes non-linear least-squares fitting to extract the optical constants and growth 
rates of the various layers without requiring any a priori knowledge of their values. The 
application achieves this by automatically calculating the necessary initial estimates for the 
fitting routine from the extrema and inflection points in the measured reflectivity, which it 
obtains using digital filtering techniques. 

3.5.1 Technical details 

To accomplish an accurate fitting, the following requirements must be met. 

 Accurate absolute reflectivity values: To ensure this, use a bare sample of known 
reflectivity to perform a calibration before starting the deposition. If any errors arise from 
mis-calibration or absorption from coated viewports, the system can use an adjustable 
scaling factor s to address them. This scaling factor relates the measured reflectivity 
values to the fitted reflectivity as follows: 
𝑹𝑹𝒎𝒎𝒎𝒎𝒎𝒎𝒎𝒎 = 𝒔𝒔 ∙ 𝑹𝑹𝒇𝒇𝒇𝒇𝒇𝒇 
If the optical constants of the film are known with confidence, their values can be fixed. 
This mode requires only a relative (rather than absolute) reflectivity measurement. 
However, the accuracy of the results depends on the accuracy of the supplied optical 
constants. In this case, the best-fit value of the scaling factor s is a calculated value. The s 
value can indicate the accuracy of the supplied optical constants. 

During film growth, the reflectivity at a given wavelength (λ) oscillates with a period 
equal to 𝜆𝜆

2𝑛𝑛𝑛𝑛
 , where G is the growth rate. Since the product nG is fixed by the oscillation 

period, any error in G results in an equal but opposite error in n. (G and s are strongly 
correlated; a change in s is accompanied by roughly the same percentage change in G, 
but in the opposite direction.) This highlights the need to determine absolute reflectivity 
to obtain accurate growth rates. 

 A minimum of one extremum and one inflection point: (i.e., a quarter of an oscillation 
period). A conservative rule of thumb is that the minimum measurable thickness is 
approximately 𝜆𝜆

4𝑛𝑛
. To obtain the best fit, the sampling rate should be large enough 

relative to the growth rate to give at least 15-20 data points per oscillation period. 
 Acceptable film roughness: If the film is too rough, this can lead to significant damping of 

the reflectivity. Accurate values for the extinction coefficient k require several oscillations 
to determine the absorption-induced damping. The greater the damping, the greater the 
number of oscillation periods required. 

 Wavelength: The choice of wavelength typically represents a trade-off between using a 
shorter wavelength, which gives a shorter oscillation period (and hence a lower minimum 
thickness) and a longer wavelength, which has lower absorption for typical materials (and 
hence a greater maximum thickness). As a rule of thumb, it is best to use the lowest 
possible wavelength that does not produce heavily damped oscillations. In addition, the 
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light must be monochromatic, with bandwidth ∆λ roughly 10 nm or less. This is dictated 

by the requirement that the coherence length 𝜆𝜆
2

Δ𝜆𝜆
 be much larger than the optical 

thickness of the film, i.e., Δ𝜆𝜆 ≪ 𝜆𝜆2

𝑛𝑛𝑛𝑛
. 

 Polarization: If you perform the reflectivity measurement at a non-normal incidence 
angle, you must distinguish the two polarizations of reflected light. The reflectivity of p-
polarized light becomes very sensitive to the incidence angle near Brewster’s angle. 
Therefore, k-Space does not recommend that you use this polarization unless the 
incidence angle is known precisely and is not subject to drift during deposition (such as 
due to rotation-induced substrate wobble). 

For best results, analyze films with high-amplitude oscillations of two to three periods. To 
obtain such oscillations, deposit materials with large differences in refractive indices. You 
should also choose the film thickness such that the new layer starts when the reflectivity of 
the underlying structure differs as much as possible from the bulk reflectivity of the new film 
material. 

For example, if the index of the growth layer is greater than that of the underlying layer, the 
oscillations will be maximized if the underlying layer thickness is such that its reflectivity is at 
a minimum. If, on the other hand, the index of the growth layer is less than that of the 
underlying layer, the oscillations will be maximized if the underlying layer thickness is such 
that its reflectivity is at a maximum. The images below illustrate these two cases. Typically, 
the calibration process is designed to take full advantage of these effects, but for in situ 
control, it must deal with the interference patterns that result from the desired device 
structure. 
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The algorithm also provides estimates of the standard error for each fitted parameter. It is 
important to examine these error estimates before using the results for process control. The 
standard error estimates for each parameter represent 1-σ values, under the tacit 
assumption that the reflectivity values are perfectly accurate. In practice, this is difficult to 
achieve in the presence of wobbling substrates, light source instability, and drifts in the 
electronics. With care, it is possible to control these effects to better than one percent. 

3.5.2 Performing a reflectivity fit 

Follow the procedure below to perform a reflectivity fit. 

1. Open the desired montage plot (.img) file and select Analysis > Vertical Line Profile to 
create a Vertical Line Profile. 

2. Select the line in the image window and drag it to the desired wavelength (as indicated at 
the top of the Vertical Line Profile window). 

3. (Optional) Define the time range for which to display the data. 
a. In the Vertical Line Profile window, place the cursor at the desired minimum X value. 
b. Right-click that location and select Set X Min. The plot removes all data to the left of 

that point and shifts the plotted data such that that point is the minimum X value. 
c. Place the cursor at the desired maximum X value, right-click, and select Set X Max. 

The application removes all data to the right of that point and shifts the plotted data 
to fill the plot window. 

4. (Optional) Smooth the data by applying up to five data filters. For example, to apply a 4th 
order Butterworth low-pass filter, follow these steps. 
a. Right-click the chart, select Properties, and click the Data Filters tab. 
b. In the first drop-down list, select Butterworth and then click the Properties button. 
c. In the Properties dialog, enter the desired Smoothing Factor, which is the ratio of the 

filter’s time constant to the data sampling interval. Note that this introduces a lag 
that is proportional to the smoothing factor. The default value is 1 (no smoothing). 
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d. To add other filters, select them in the subsequent rows. 
e. Click OK to apply the selected filters. 

5. Select Analysis > Reflectivity Fit to open a chart that displays the fitted film thickness, 
growth rate, and optical properties. 

 

To configure the fit, right-click the plot window, select Properties, click the Reflectivity 
tab, and specify the reflectivity parameters. As with any fitting algorithm, the better the 
estimate of the fitting parameters, the faster the convergence. In the Virtual Interface 
algorithm, either n and k, or s must be locked, allowing the unlocked parameters to be 
calculated. Note that when the fit converges, the n, k, and G fields contain the fitted 
values, which are also displayed on the chart. 
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Field Name Description 

n Index of refraction of the deposited material. If unknown, enter 1 
(i.e., vacuum). 

k Extinction coefficient (i.e., imaginary part of the complex index of 
refraction) of the deposited material. If unknown, enter 0 (i.e., no 
absorption). 

G Estimated growth rate (in nm or µm) per unit time. If unknown, 
enter 0. 

s Reflectivity scale factor for the fit, intended to account for such 
things as absorption from a coated viewport or reflectivity 
calibration errors. This parameter relates the measured reflectivity 
values to the absolute reflectivity via 𝑹𝑹𝒎𝒎𝒎𝒎𝒎𝒎𝒎𝒎 = 𝒔𝒔 ∙ 𝑹𝑹𝒇𝒇𝒊𝒊𝒕𝒕. You can 
adjust this, unless n and k are locked at specific values, in which case 
the best-fit value of s is a calculated value. 

Lambda The application automatically enters the wavelength value of the 
vertical line profile, but you can enter a different value. 

Angle  Angle of incidence of the incoming light source beam, with respect 
to the normal to the surface. 

Polarization Type Choose the applicable polarization type, as described in the two-
port option section. 

Max Fit Iterations Maximum number of attempts to fit the data. If, for some reason, 
the fit fails to converge, try increasing this number. 
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 How to Set the Spectra Phase Delay 
Follow the procedure below to set the phase delay. 

1. Select the applicable spectrometer from the View menu or click the  button on the 
toolbar to open the Live Spectrometer window. 

2. Right-click the Live Spectrometer window and select Properties. 
3. On the Spectrometer tab, use the slider to set the desired integration time, and verify 

that the External trigger box is checked. 
4. Click the Rotation Monitor tab, and enter the desired number of rotation positions. 

 

The application evenly divides each rotation period into this number of positions. 
 

 Note 

The total acquisition time (spectrometer integration time multiplied by number of positions, plus 
processing time) must be less than the rotation period. 
For example, for a rotation rate of 30 RPM, the rotation period is 2 sec. If the integration time is 
20 ms, the maximum number of rotation positions per cycle is 100 (2 sec/20 ms). If you reduce 
this by 10% to allow for processing time, etc., the result is 90 rotation positions. If this number is 
too large, the measurements will fall out of synchronization. 

 

5. Open the Spectra Phase Delay Selection Acquisition window, and then select the desired 
spectrometer in the Acquire source field. 

6. Verify that the platter is rotating and check the value in the Rotation Positions field. 
7. Open the Real-time Phase Delay Section RTC. 
8. Click Start when you are ready to begin the acquisition. 

When acquisition starts, the rotation monitor will attempt to lock on to the RPM of the 
rotating platen. After several rotations, the RPM estimate will lock, and the plotted line 
will begin to re-trace itself. The highest value on the Phase Delay axis should be the value 
of the largest rotation position (i.e., total number - 1). For example, if you use the default 
value of 250 rotation positions, the display should read 249. If not, decrease the number 
of rotation positions and/or the integration time. 

9. Allow the acquisition to run for several rotations to ensure that the system is working 
properly, then click the Stop button. The RTC places a marker at the location that 
represents the current phase delay. You can move the marker by clicking the triangle at 
the top and dragging it to the desired position. 
This defines the phase delay value that the application will use going forward. To save 
this value, click the Set Phase Delay button or close the Spectra Phase Delay Selection 
Acquisition window. 
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 How to Calibrate the Spectrometer 
k-Space calibrated the kSA SpectR spectrometer prior to shipment. However, during 
shipment, the spectrometer was subject to mechanical and thermal shock that may have led 
to a small spectral shift — on the order of 0.5 to 1 nm. To determine if a post-shipment 
correction is needed, perform a Mercury-Argon (Hg-Ar) line source calibration. If a correction 
is needed, this procedure determines the magnitude of that correction. 
 

 Note 

For maintenance purposes, you should perform a new Hg-Ar calibration and acquire a new dark 
background every 6 months. You must also acquire a new reference after a Hg-Ar calibration to 
correct for any shift in the spectra. 

 

1. Install the kSA lens tube spacer between the fiber and spectrometer input to reduce the 
intensity of the HgAr source. 

2. Select Acquire > Spectrometer Calibration. 
3. In the Spectrometer Calibration Acquisition window, click the Advanced button. 
4. In the Advanced Acquisition Options dialog, click the Advanced Settings tab, and check 

the Hg 546.1nm and Hg 763.5nm boxes in the Select Spectral Lines section, and click OK. 
5. Wait at least 15 mins for the spectrometer to reach operating temperature. 
6. Choose the Calibrate for option, and then enter 30 in the Sec field. 
7. Right-click the Live Spectrometer window and select Properties. 
8. On the Spectrometer tab, adjust the integration time to ensure that the spectrometer is 

not saturated (typically between 20 and 40 msec). 

9. If the magnitude of the indicated shift in wavelength is ≥ 0.2 nm, accept the new 
calibration when prompted. The application will save the settings in the spectrometer 
.stp file and reinitialize the spectrometer. 

 

 Note 

Be sure that the shift to does not exceed ± 1.5nm. The wavelength of the Hg 546 line may end up 
high and the 763.5nm line low. It is not possible to match both. 

If the shift exceeds ± 1.5nm, contact k-Space for assistance. 
 

10. Click the Snapshot  button on the Live Spectrometer toolbar to capture a snapshot of 
the spectrum, and save it as a .kdt file (for example, SNAA0758 HgAr.kdt). Re-run the 
calibration in Continuous mode to verify that the calibration correction is within the 
acceptable limits. 

11. Acquire a post-calibration dark background, and save the dark background .kdt file. 
12. Reconnect the spectrometer fiber optics cable to its original port. 
13. Remove the HgAr cable and store it in a protected location. 
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4 Configuring the kSA SpectR Software 
The kSA SpectR software includes numerous options that allow you to customize the 
operation and various aspects of the application. You can access these options through the 
commands on the Options menu. The settings you choose for these options apply to all users 
for all acquisition modes and analysis tools. 

 

 General and Input/Output Device Options 
The Options menu provides access to the General Options dialog and the Input/Output 
Device Options dialog. These dialogs include multiple tabbed pages that contain options for 
controlling the general operation and functionality of the kSA SpectR system and options for 
configuring the analog and digital input and output boards, respectively. 

For a detailed description of each option and setting, refer to Appendix A: General Software 
Options and Appendix B: Input and Output Device Options. 

 Data and Activity Logging 
The kSA SpectR software records details on errors and certain activities that occur while the 
application is running. Each time an error or a selected activity occurs, the application records 
relevant information (error, activity, date and time, etc.) in the log file and saves the file in 
the folder specified in the Logs field on the General Options > Directories tab. The log file is in 
standard text .txt format, so you can view it using any text editing application. 
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 Select Options > Logging to access the following commands. 

 High/Medium/Low: Applies the selected logging level. 
 View. Opens the current log file in Microsoft Notepad. 
 Logging Settings. Opens the Logging Settings dialog, where you can specify options 

for the data and activity log files. The fields in this dialog correspond to the fields on 
the General Options > Logging tab. 

 

 Saved Software Settings 
You can save all current kSA SpectR application settings in a kSA personality (.ksaxml) file. 
These files contain settings for all the windows and dialogs in the kSA SpectR software (i.e., 
any kSA SpectR setting that you can update in the computer registry). 

When you load a personality file, the application will apply those settings whenever you open 
the kSA SpectR application, ensuring consistent settings and consistent results. 

Follow these steps to save your kSA SpectR software settings. 

1. Verify that all custom settings are exactly the way you want them, and that all windows, 
dialogs, and plot windows that you want to display are open in the main window. 

2. If an acquisition window is open, close it; this will also close all open real-time charts. 



Configuring the kSA SpectR Software 
 

kSA SpectR User Manual 33 

3. Select Options > Save Settings. 
4. In the Browse for personality file dialog, navigate to the applicable folder location, and 

enter a descriptive file name for the settings file. 
5. Click the Save button. 
The application saves all kSA SpectR settings, including your custom settings. The process 
may take several seconds to complete. 
 

 Note 

You can check the Save settings at program exit box on the General Options > General tab to 
automatically load the current settings each time you open the kSA SpectR application. 

 

After you create one or more personality files, you can load the settings contained in those 
files, as follows. 

1. Select Options > Load Settings. 
2. The application displays a prompt asking you to confirm that you want to load archived 

preferences. If you click Yes, the application will overwrite the current settings with those 
from the saved personality file. 

3. In the Browse for personality file dialog, navigate to and select the applicable personality 
file, and click the Open button. 

4. When prompted to reinitialize all boards, click Yes to apply your custom settings 
immediately. 

 Software User Mode 
The kSA SpectR application can be run in two different modes — Engineer or Operator. This 
may be useful in cases where you want to restrict certain users from accessing the 
configuration options and advanced acquisition options areas of the application. 

 To select the user mode, select Options > Admin or click the  button on the toolbar. 
Select the desired mode from the User mode drop-down list, and then click OK. 

 

 The Engineer mode provides full access to every window, dialog, and command in the 
kSA SpectR application, and the Select User mode dialog includes the Reset Workflow (to 
start the pre-defined workflow from the beginning) and Admin Tools (to open the 
Administrator Tools dialog) buttons. 
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 The Operator mode has access to only certain acquisition modes and read-only access to 
options dialogs. 

4.4.1 Administrator Tools 

Use this dialog to specify workflow options and the default user level. This dialog is available 
only when the kSA SpectR software is in Engineer mode. 

 To access the Administrator Tools dialog, click the Admin Tools button in the Select User 
Mode dialog. 

 

Field Name Description 

Enforce Acquisition 
Workflow 

Forces the user to work through the procedures in a pre-defined 
workflow. 
 Allow previous steps: Keeps the previous steps in the workflow 

enabled so that you can go back to them. 
 Allow Non-admin to reset workflow: Enables the Reset Workflow 

button (in the Select User Mode dialog) for all user modes. 

Startup User Level User mode in which to open the kSA SpectR application every time. 
 Use level at shutdown: Opens in the user mode that was in use the 

last time the system shut down. 
 Use designated level: Opens in the user mode selected here. 

 



 

kSA SpectR User Manual 35 

5 Common Tasks in the kSA SpectR 
Software 
As with any software application, there are certain tasks that you will perform frequently in 
the kSA SpectR software. This chapter describes some of the most common tasks. The 
commands for these tasks are available on the File, Edit, and Window menus. 

 Opening Data Files 
When you acquire data with the kSA SpectR, you can save them in proprietary k-Space file 
formats. You can use these files for data analysis, and in some cases, you can select a data file 
instead of a spectrometer as the data source in the active data acquisition window.  

You can open a kSA SpectR data file using any of the following methods. 

 Browse to the applicable file using any of the following commands. 

 Click the Open  button on the toolbar. 
 Select File > Open. 
 Press CTRL+O on your keyboard. 

 Select a recently saved file from the Most Recently Used (MRU) list on the File menu. The 
MRU list includes up to the last 10 saved data files opened in the kSA SpectR application. 
The files are listed in the order they were opened, with the most recent file at the top. 

 



Common Tasks in the kSA SpectR Software 
 

kSA SpectR User Manual 36 

5.1.1 kSA SpectR file formats 

The kSA SpectR application saves data in several different proprietary file formats. Because 
external applications cannot read data from kSA proprietary files, the kSA SpectR software 
provides several options for exporting the data to other more common formats. 
 

Filename 
Extension 

Data Type File Contents 

bsrf Reference Reference spectrum acquired through a reference acquisition to 
normalize the acquired spectra. During data acquisition, the 
application uses this spectrum to normalize the spectra as they 
are acquired. 

exprt Custom export Settings for a custom data export. 

img Scan Mode 
image 

Scan Mode image data generated during data acquisition. 

kdt Acquired data Data acquired via the various data acquisition modes. The 
specific contents of the .kdt file depends on the acquisition 
mode used to acquire the data. 
In many cases, you can select a .kdt file as the spectra source in 
the data acquisition window, and acquire data from the file as if 
it were a live spectrometer. 

ksaxml Saved settings All current software settings for the kSA SpectR application. 

log Data and 
activity logs 

Record of activity that occurs as you use your kSA SpectR system 
for data and activity logging purposes. 

stp Spectrometer 
source 

Parameters for the kSA SpectR spectrometers, including the 
wavelength range of the spectrometer and any correction shift 
determined by a Hg-Ar line source calibration. 

 Saving and Exporting kSA SpectR Data 
After you acquire data or complete an analysis, you can save the data for future reference. 
When you save data, the application retains the original data, which include details that are 
specific to the kSA SpectR application and that only k-Space software can read. 

The kSA SpectR software includes options for exporting the data to other formats to enable 
you to view the information in other applications, such as Microsoft Word or Excel or other 
graphics applications. When you export data, the application retains the original data in the 
selected format, but it does not export the data that are specific to the kSA SpectR. 

5.2.1 Saving kSA SpectR data 

k-Space recommends that you save all acquired data in the proprietary kSA file formats. 
These files contain data that are specific to the kSA SpectR and allow you to use the built-in 
data analysis tools on those data. 
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Use any of the following methods to save the data in the active window. 

 Click the Save  button on the toolbar. 
 Select File > Save.  
 Press CTRL+S on your keyboard. 
 Select File > Save As to specify a name for the file. 
 Set up the application to save data automatically by enabling the Store Incrementally 

and/or Auto-save documents options on the Advanced Acquisition Options > Document 
Generation tab. 

5.2.2 Exporting kSA SpectR data 

There may be times when you need to view kSA SpectR data in non-kSA applications. Because 
the k-Space proprietary format is not compatible with third-party applications, the 
kSA SpectR application allows you to export data to other formats. The exported data will not 
include the same details as those saved in proprietary k-Space format. 

The kSA SpectR application offers three options for exporting data — standard export, 
custom export, and batch export. 

Standard export 

Follow these steps to export data contained in the active window. 

1. Select the window that contains the data to export. 
2. Select File > Export to open the Export Plot or Export Image dialog. 

The data formats available for export depend on the type of data you are exporting. For 
example, the following options are available for exporting acquired spectral data. 

 

3. Select the format for the exported data, and then click OK. 
4. In the Save Copy As dialog that opens, select the appropriate folder location for the 

export file, enter a descriptive file name, and click Save. 

Custom data export 

For most kSA SpectR data types, you can select specific data to include in the export file and 
specify options for the data, and then you can save these settings as a custom export recipe 
(.exprt) file. 
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1. Select the window that contains the data to export, and then select File > Export. 
2. In the Export Plot dialog, select Custom Data from the drop-down list, and click OK. 
3. In the Custom Data Export Selection dialog, select the desired export file type from the 

drop-down list in the Export Format section, and then specify the remaining parameters 
as applicable. 

 

Field Name Description 

Export Format Format for the exported data. 
To load settings from a saved export recipe file, click the Load button. To 
save the current settings to an export recipe file, click the Save button. 

Available / 
Exported 

Use the Select , Select all , Remove , and Remove all  
buttons to move the data types to export between the Available and 
Exported panes. 
The data are stored in the order listed in the Exported pane. To change 
the order, highlight the data types in the Exported pane and click the Up 
or Down button to move them to the preferred positions. 

Export Filter Setup You can exclude certain data from the export file by selecting a filter 
(data points or elapsed time) and specifying the range of data to exclude. 
To export all applicable data, select <None>. 
To further reduce the amount of exported data, check the Reduce Data 
box and specify the number of data points to skip. 
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Field Name Description 

Options  Synchronize Time-Of-Day: Uses the time stamp from the original .kdt 
file. To use the time that the export file was created, clear this box. 

 Export property pages: Exports all data available in all tabs in the Plot 
Properties dialog (many of these parameters are not listed in the 
Available pane). 

 Export each region as a separate column: (N/A for the kSA SpectR) 
 Select region(s) to export: (N/A for the kSA SpectR) 
 Export wide columns as rows: Exports each element in the array as a 

separate row, instead of exporting each as a column. This makes the 
output file long instead of wide. 
Check the Skip line between data points to add a blank line between 
each data point to break up the data in the export file. 

 

4. After you have selected the data to export and specified the application options, click OK. 
5. In the Save As dialog that opens, select the appropriate folder location for the export file, 

enter a descriptive name for the file, and click Save. 
 

 Tip: Automatically export custom data 
You can set up the kSA SpectR to automatically export data using a custom export recipe at the end 
of every acquisition by checking the Auto Export data box on the Advanced Acquisition Options > 
Document Generation tab, choosing the Custom using option, and selecting the preferred custom 
export recipe file. 

Batch export 

The kSA SpectR software enables you to export data from multiple files into a single export 
file. Note that all files included in the batch must be of the same file type. 

1. Select File > Batch Export. 
2. In the Open dialog, select the files to include in the export file, and then click the Open 

button. 
 

 Note 

By default, the Open dialog lists all available .kdt files. You can select a different proprietary 
k-Space file format from the drop-down list in the lower-right corner of the Open dialog. 

 
 

3. In the Custom Data Export Selection dialog, specify the export options. 
4. Click OK to begin the export. When the export is complete, the application displays the 

export results. 
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 Printing Plots and Data 
Use any of the following methods to print data from the active window. 

 Click the Print  button on the toolbar. 
 Select File > Print. 
 Press CTRL+P on your keyboard. 
The application opens the standard Windows Print dialog, where you can select options for 
your specific printer and specify the pages and number of copies to print. 

To select the orientation and paper size for the printed file, select File > Print Setup. 

 Copying and Pasting Images and Data 
You can use any of the following methods to copy data from the active window to the 
Windows clipboard. You can then paste the clipboard contents into other applications, such 
as Microsoft Word or Excel or Paint. 

 Click the Copy  button on the toolbar. 
 Select Edit > Copy. 
 Press CTRL+C on your keyboard. 
 Right-click the active window and select Copy. 

5.4.1 Pasting Windows clipboard contents 

When you copy data from a Scan Mode image (.img) window, the copied content will always 
be pasted as an image, regardless of the application into which you’re pasting the content. 

When you copy data from a kdt plot window, you have the option to paste the data as an 
image or as formatted numerical data in certain applications. 

 Graphics applications: (e.g., Microsoft Paint) The content will always be pasted as an 
image. 



Common Tasks in the kSA SpectR Software 
 

kSA SpectR User Manual 41 

 

 Simple text editor: (e.g., Microsoft Notepad) The content will always be pasted as 
formatted numerical data. 

 

 Word processors or spreadsheets: (e.g., Microsoft Word or Excel) By default (when you 
press CTRL+V), the contents will be pasted as formatted numerical data. 
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To paste the clipboard contents as an image, click the arrow on the Paste button on the 
Home ribbon, and then select the Paste Special option. 

 

In the Paste Special dialog, select Bitmap, and then click OK. 

 

The contents will be pasted into the application as an image. 
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 Setting Data Display Properties 
Each open data or analysis window in the kSA SpectR application has an associated Properties 
dialog that contains options for customizing the data displayed in the plot window. 

 Use any of the following methods to open the Properties dialog for the active window. 

 Select Edit > Properties. 
 Right-click the window and select Properties. 

 For the Live Spectrometer window, click the  button on the Live Spectrometer 
toolbar. 

 For real-time chart windows, double-click inside the window. 
The Properties dialog that opens depends on the active window. 

 Live Spectrometer window: The Spectrometer Properties dialog includes options that 
affect the way the spectrometer acquires data. 

 Scan Mode image window: The Image properties dialog includes comments and details 
on the settings used to acquire the image. 

 kdt plot window: The Plot Properties dialog includes options that affect the way the data 
are plotted, without affecting the original acquired data. 

 Arranging Open Data and Plot Windows 
The Window menu includes the following commands for switching between open windows 
and choosing how those windows are arranged in the main window. 

 Cascade: Displays all open windows, one on top of the other, such that the title bar for 
each window is visible. To quickly switch between windows, click the title bar for the 
window you want to view. 
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 Tile: Resizes all open windows so that they fit in the main window without overlapping.  

 

 Close all: closes all open windows at the same time, so you do not need to close them 
individually. 

 <window name>: The Window menu includes a list of all open windows and denotes the 
active window with a checkmark to the left of the window name. To quickly switch 
between windows, select the preferred window from the menu. 

 

 Getting Help 
Use the commands on the Help menu to access information about your kSA SpectR software. 

 User manual: Opens a searchable PDF of this kSA SpectR User Manual. See Finding 
Information in This User Manual for information on searching for specific content. 

 About: Displays the kSA SpectR software version information and provides access to 
k-Space contact information. 
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 Contact and Support Info: Provides links to contact information for k-Space. 
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6 Data Acquisition Modes in the 
kSA SpectR Software 
The kSA SpectR system includes several data acquisition modes that enable you to capture 
very extensive and wide-ranging data. You can view and analyze these data using the various 
kSA SpectR real-time and post-acquisition analysis tools. 

During data acquisition, the application captures and stores data in .kdt data files using a 
proprietary k-Space data format. 

The following data acquisition modes are available for kSA SpectR systems. Note that not all 
modes are applicable to every system. 

 Common Acquisition Parameters 
Most kSA SpectR acquisition modes include the following fields and buttons. 

 Data source: Source of the acquired data. This could be a spectrometer or, in some cases, 
a spectral .kdt file. If you select a spectral .kdt file, the application will acquire data from 
the file as if it were a live feed. 
The name of the data source field depends on the acquisition window. For example, in 
the Dark Background Acquisition window, it is named Spectra source; in the Single-wafer 
Spectra Reflectivity window, it is named Spectral Reflectivity; etc. 

 Acquired data file name: Name of the file to save the acquired data in. The name of the 
acquired data file field (Run name or Archive name) depends on the acquisition window. 
This field may be grayed out and unavailable, depending on the selection in the File name 
format field on the Advanced Acquisition Options > Document Generation tab. 
 If you selected Manual run name, the Archive name field will be available, and you 

must enter a name for the data file. 
 If you selected Auto-incrementing run name, Date/time-based run name, or Base 

Name Only, the field will be grayed out, with the default file name already entered. 
 Advanced button: Opens the Advanced Acquisition Options dialog, where you can choose 

options for the current acquisition. 
 Start/Close buttons: The Start button initiates data acquisition. During acquisition, the 

labels for the Start and Close buttons change to Pause and Stop, respectively. 
The Close button closes the acquisition window and any open real-time analysis 
windows. 
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 Dark Background Acquisition 
The Dark Background Acquisition mode obtains spectral data in the absence of light. These 
spectra represent the inherent background noise that is present even in the absence of an 
external signal. The application automatically subtracts the background spectra from the 
measured spectra to provide the cleanest spectra for analysis. 

 To access the Dark Background Acquisition window, select Acquire > Dark Background or 

click the Dark Background  button on the toolbar. 

 

Field Name Description 

Spectra source Select the applicable spectrometer as the data source. 
Dark background data are spectrometer-specific, so you must select the 
spectrometer you will use for data acquisition. 

Archive Name Name of acquired data file. 

Samples per datapoint Number of samples to take for each data point. Sampling serves to 
reduce random noise by averaging multiple spectra together. 

Min / Max / Step These fields define the range of integration times (Min/Max) for which to 
acquire dark background data and the increment (Step) by which to 
increase each successive integration time. See Specifying integration 
times for important information. 

Light Source in standby 
during acquisition 

Puts the light source is in standby mode, to eliminate as much light as 
possible in the chamber. 

 Flat Field Correction Acquisition 
The Flat Field Correction Acquisition mode can be used to acquire a correction curve that 
serves to “flatten” the spectrometer’s inherent wavelength-dependent response. If needed, 
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k-Space performs this procedure prior to shipping the system and, under normal 
circumstances, you should not need to repeat it. 

 Peak Intensity Alignment Acquisition 
Use the Peak Intensity Alignment Acquisition mode to facilitate alignment of the optical 
assemblies. When this mode is active, the Real-time Peak Intensity Over Time RTC is 
available. You can maximize the reflected intensity by observing the peak intensity vs. time on 
the RTC to ensure that the source and detector optics are precisely normal to the sample (for 
single-port systems) or specularly opposed with respect to the sample (for two-port systems). 

 To access the Peak Intensity Alignment Acquisition window, select Acquire > Peak 
Intensity Alignment Acquisition. 

 

Field Name Description 

Peak Intensity Select the applicable spectrometer as the data source. 

Run name Name of the acquired data file. 

Amount of data to 
acquire 

Choose the amount of data to acquire. 
 Duration: Acquires data for the exact length of time specified in the 

Hour, Min, and Sec fields. 

 Note: You can enter up to 4 digits for both seconds and minutes 
and up to 3 digits for hours. The application will convert to the 
appropriate number of hours/minutes/seconds, if needed. 
For example, if you enter 9999 seconds, the application will convert 
the duration to 2 hr, 46 min, and 39 sec. 

 Continuous (no data saved): Acquires data continuously, until you 
click the Stop button. You can monitor and analyze the data as it’s 
acquired, but the application does not save the data. 

Advanced Opens the Advanced Acquisition Options dialog. 
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 Reference (Single-wafer) Acquisition 
The Reference (Single-wafer) Acquisition mode captures reference spectra while the platen is 
stationary. The application uses reference spectra to normalize the measured spectral 
reflectivity to that of a bare substrate, typically obtained just prior to growth. 

 Select Acquire > Reference (Single Wafer). 

 

Field Name Description 

Spectra source Select the applicable data source. 

Archive name Name of the acquired data file. 

Samples Number of samples to acquire. It is helpful to acquire multiple samples 
to reduce random noise. 

Processing intensity 
floor 

Minimum peak intensity value that a spectrum must possess to be 
considered valid. The application will ignore any spectra with peak 
intensities below this value. 

Auto-select reference Automatically selects the new reference when the acquisition is 
complete. 

Advanced Opens the Advanced Acquisition Options dialog. 

 Single-wafer Spectral Reflectivity Acquisition 
The Single-wafer Spectral Reflectivity Acquisition mode measures reflectivity, film thickness / 
growth rate, and optical constants (n, k) simultaneously. The application saves a .kdt file 
containing the Fabry-Perot Dip spectra (both raw and normalized) when you use this mode to 
acquire data. You can also use this mode to create montage plots in the form of scan-mode 
images (.img). 

 Select Acquire > Single-wafer Spectral Reflectivity or click the  button on the toolbar. 
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Field Name Description 

Spectral Reflectivity Select the applicable data source. 

Reference Name of the file that contains the reference spectrum to use. 

Run name Name of the acquired data file. 

Amount of data to 
acquire 

Choose the amount of data to acquire. 
 Duration: Acquires data for the length of time specified in the Hour, 

Min, and Sec fields. 
 Continuous (no data saved): Acquires data continuously, until you 

click the Stop button. You can monitor and analyze the data as it’s 
acquired, but the application does not save the data. 

Advanced Opens the Advanced Acquisition Options dialog. 

 Spectra Phase Delay Selection Acquisition 
The Spectra Phase Delay Selection Acquisition mode sets the rotational position at which to 
acquire data. The application uses the phase delay to ensure that data acquisition occurs 
when the sample is in that position. After the system receives a Home pulse, the application 
delays the triggering the spectrometer by the selected amount. 

 Select Acquire > Spectra Phase Delay Selection. 
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Field Name Description 

Acquire source Select the applicable data source. 

Rotation Positions Number of rotation positions to track. 

Current RPM Number of revolutions that the sample makes every minute on the 
rotation stage, if known. 

Set Phase Delay Sets the position marker at the current position. After that point, the 
system will be triggered to take a snapshot of data only when the stage 
rotation reaches this position. 

Advanced Opens the Advanced Acquisition Options dialog. 

 Spectrometer Calibration Acquisition 
The Spectrometer Calibration Acquisition mode verifies that the spectrometer is properly 
calibrated by comparing acquired spectra against known spectral lines from a special Hg/Ar 
lamp. k-Space performs this calibration during instrument commissioning, but there may be 
times when you may need to calibrate the spectrometer. 
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Field Name Description 

Spectra Source Select the spectrometer to calibrate as the data source. 

Calibrate for/ 
Continuous/ 
All available data from 
source 

Amount of data to acquire for the calibration. 
 Calibrate for: Runs the calibration for the exact length of time 

specified here. You must also enter the name or ID of the operator 
who is performing the calibration in the Operator field. 

 Continuous: Runs the calibration continuously, until you click the Stop 
button. The application does not save the acquired data. 

 All available data from source: Uses all data from a saved .kdt file. 

Current Calibration  The application enters this information from the current calibration. 
 Calibration Date: Today’s date. 
 xStart: Starting wavelength in nm. 
 Shiftnm: Overall wavelength shift (in nm) to apply, relative to the 

original factory settings. 
 Shift Enabled: Shift status — 1 (shift is enabled) or 0 (shift is disabled). 

Advanced  Opens the Advanced Acquisition Options dialog. 
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7 Data Analysis 
In addition to the numerous data acquisition capabilities available for the kSA SpectR system, 
the kSA SpectR application also includes many powerful analysis tools. For example, the Real-
time Charts and Montage plots are particularly useful. 

 Real-time Charts 
The kSA SpectR application includes numerous real-time charts (RTCs) that allow you to view 
raw and processed data in real-time. These charts provide valuable data and information that 
you can analyze as they are being acquired. You can open multiple RTCs for each acquisition, 
enabling you to monitor several aspects of the acquisition simultaneously. 

 To view one or more RTCs, open a data acquisition window, and then select the desired 
RTCs from the View menu. The RTCs that are available for selection depend on the 
selected data acquisition window. 

 

 Notes 
 Each RTC has an associated Plot Properties dialog that is comprised of several tabbed pages with 

options and settings that control how the data are displayed in the plot window. 
 For most RTCs, you can select the parameter to plot from the drop-down list on the Plot 

Properties > Data tab. 
 Several RTCs include a Snap Shot button. During acquisition (or after acquisition is complete), you 

can click that button to capture data at the current point. The application automatically saves 
the data in a file of the appropriate type (based on the acquisition mode). 

7.1.1 Overall Reflectivity  

RTC, which displays the live reflectivity measurements and the reflectivity of the reference 
used to calibrate the system (green trace). 
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This MultiSource chart can display data from multiple spectrometers simultaneously. For 
example, the plot above shows the reflectivity of GaAs measured using a dual-spectrometer 
system. The blue trace represents the output from a visible spectrometer; the red trace 
represents the output from a NIR spectrometer. 

The Export button at the lower left can be used to automatically save the data to the Output 
directory in the form of a txt file in (see the SpectR Software Installation Guide for details 
regarding setting the various file directory locations). 

7.1.2 Real-time Stats  

RTCs allow you to view raw and processed scalar data as a function of elapsed time during 
acquisition. The Clear button at the lower left can be used to clear the displayed data and 
reset the minimum value of the time scale. 
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7.1.3 Spectra RTCs  

allow you to customize the display by choosing from the following dropdown list on the Plot 
value tab.  

 

Item Description 

Light Off Spectra Raw spectra acquired with the light source’s shutter closed (if in use). 

Light On Spectra Raw spectra acquired with the light source’s shutter open (if in use). 

Light - Dark Spectra The difference between the shutter open and shutter closed raw spectra 
(if in use). 

Normalized Spectra Raw spectra divided by the reference spectrum. 

Reference Absolute 
Reflectivity 

Absolute reflectivity of the reference used to calibrate the system 
(static). See Reference Acquisition for more details. 

Reference Spectra The raw reference spectrum (static). 

Reflectivity The calculated absolute reflectivity spectra. 

Spectra The current spectrum (same as the Real-time Spectra RTC). 

The configuration of the three Spectra RTCs shown below (Light Off Spectra, Light On 
Spectra, and Light - Dark Spectra) is particularly useful when using the light source’s shutter, 
as it illustrates its effectiveness at removing stray light which might otherwise compromise 
the reflectivity measurement. 

 

The Snap Shot button at the lower left can be used to open a new window containing spectra 
data that can be saved as a .kdt file, or exported in a variety of different formats 
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7.1.4 Real-time Fabry-Perot  

RTC can be used to display the results of the Fabry-Perot Dip and/or Passband Edge detection 
feature. While the acquisition is running, click the F-P Dip button at the lower left to trigger 
the measurement(s). 

This feature uses the settings on the Extrema Finder tab of the Spectrometer Configuration 
Options dialog. If the application finds an extremum that is not a valley, or if it finds multiple 
extrema, the system generates an error condition. Every time the application initiates a 
measurement, it creates an entry in the Fabry-Perot Log, which you can access from the View 
menu. The log entries include the time of day, time elapsed since the start of the data 
acquisition, time elapsed since the measurement was requested, and the measurement 
results. 

In addition, the application saves the spectra (both raw and normalized) in a .kdt file. Note 
that you can also initiate the measurement via a digital input signal by checking the Find 
spectral extrema when triggered box on the Spectral Reflectivity Configuration tab of the 
Spectrometer Configuration Options dialog. 

 

7.1.5 Real-time Phase Delay Selection  

This RTC allows you to select the sample position on a rotating platen that will trigger data 
acquisition. The application places a marker on the plot to indicate the trigger position. Move 
the marker to the appropriate position by clicking the triangle at the top of the marker line 
and dragging it to the desired position. 

to open that RTC. To select the value to plot in the RTC, right-click the chart, select 
Properties, click the Plot Value tab, and then select the desired value from the Plot drop-
down list. The application plots the selected parameter as a function of the rotation position. 
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 Montage (Scan Mode Image) Plots 
The kSA SpectR application enables you to view the measured reflectivity simultaneously as a 
function of both time and wavelength, in the form of a scan mode image (a.k.a. montage 
plot). If operating in multi-wafer mode, you can acquire a separate montage plot for each 
satellite. 

To view a montage plot, open the desired scan mode image (.img) file. You can change the 
colors to distinguish the changes better by right clicking the image window, selecting 
Properties, clicking the Palette tab, and selecting the desired color palette from the Palette 
drop-down list.  

You can enhance the details in the image by re-mapping the palette to maximize the 
contrast. To do this, select Maximized from the drop-down list in the Mapping field. Note 
that as you move the cursor around the image, the application continuously updates the 
cursor position and intensity value in the status bar at bottom of the image window. 



Data Analysis 
 

kSA SpectR User Manual 58 

 

7.2.1 Analyzing a montage plot 

The kSA SpectR application includes several post-acquisition analysis tools you can use to 
analyze scan mode images. 

You can create the horizontal or vertical line profile plots from a montage plot by selecting 
the desired line profile from the Analysis menu. 

When you select a line profile, the application places a line on the line profile window and 
analyzes the data beneath the line. To move the line, click it and drag it to the desired 
location, or use the up and down arrow keys on the keyboard to move it. 

Note that you can display multiple line profiles simultaneously. 

 Horizontal Line Profile: The application places a horizontal line on the image and plots the 
data beneath the line in a separate Horizontal Line Profile plot window, as shown in the 
following image. At the top of the plot window, the application displays the time for the 
current position of the line. To display data for a particular time, move the line on the 
image until the plot shows the desired time. 
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 Vertical Line Profile: The application places a vertical line on the image and plots the data 
beneath the line in a separate Vertical Line Profile plot window, as shown below. At the 
top of the plot window, the application displays the wavelength for the current position 
of the line. To display data for a particular wavelength, move the line on the image until 
the plot shows the desired wavelength. You can perform a reflectivity fit on this data. 
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8 k-Space Service and Support 
k-Space stands behind all metrology systems and software that we provide to our customers. 
If you find that you need support or service on any k-Space products, several options are 
available. 

 Contacting Us 
k-Space provides technical support by telephone, fax, or email during normal business hours 
(Monday through Friday, between 8:30 a.m. and 5:30 p.m. ET) at no charge during the 
warranty period. On-call after-hours technical support via phone or email is also available and 
may incur an hourly charge. 

Telephone: (734) 426-7977 
Fax: (734) 426-7955 
Email (general inquiries): requestinfo@k-space.com 
Email (technical support): support@k-space.com 
Website: k-space.com 

 Onsite Service 
k-Space offers onsite technical support and servicing. All onsite work will be performed by a 
qualified k-Space field-service engineer (FSE). The rates may require a minimum charge, 
downtime fees, and travel costs. For information and quotes for onsite service, please 
contact k-Space. 

 Factory Service 
k-Space charges for the following non-warranty services that are performed at the k-Space 
facilities. 

 Processing and diagnostics 
 In-house labor 
 Replacement parts (based upon standard k-Space pricing) 
 Shipping via UPS Ground service, unless otherwise specified 

mailto:requestinfo@k-space.com
mailto:support@k-space.com
http://k-space.com/
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 Warranty 
All k-Space systems and components are warranted against defective materials and 
workmanship for a period of one (1) year from the date of delivery (including any 
consignment parts). All field services are subject to the labor costs as outlined in the Onsite 
Service section. 

k-Space will not charge labor or parts fees for service performed on warranty parts at the 
k-Space facility. k-Space customers may purchase an optional two-year warranty at the time 
of their initial order, for an additional percentage of the new unit purchase cost. 

All k-Space software improvements and upgrades made during the warranty period, deemed 
applicable by k-Space, are included. Furthermore, all software issues identified (and deemed 
applicable by k-Space) during the warranty period will be fixed by k-Space at no cost to the 
customer. Extended warranty options are also available for purchase after system installation 
and before warranty expiration. 
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Appendix A: General Software Options 
The General Options dialog includes several tabbed pages with settings that control the 
general operation and functionality of the kSA SpectR software and system. These settings 
apply to users and data acquisitions. Only the tabs that are most relevant to the kSA SpectR 
are discussed below. For information on any tabs or settings not mentioned here, please 
contact k-Space. 

 To access the General Options dialog, select Options > General. 

Directories tab 

Use the General Options > Directories tab to specify the default folder location for the 
different types of data. 

 

Field Name Description 

Personal Location to save all user-specific files. 

Output Location to save all acquired data (.kdt) files (including data files that are 
saved automatically). 

Recipe Location to look for recipe (.rcp) files that contain the kSA SpectR system 
preferences. 

Reference Location to save the kSA SpectR reference (.ref) files. 

Logs Location to save all logging (.log) files. 

Temporary Location to save temporary data files. 

Help Location of the PDF of this user manual. 
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File Settings tab 

Use the General Options > File Settings tab to enable the disk cache feature. When enabled, 
the application will write data to the disk cache before writing to the disk during data 
acquisition. 

Check the Use disk as cache box to enable the disk cache, and then specify the file size above 
which to cache the data. When a file reaches this file size during data acquisition, the 
application will write the data to the cache. 

 

General tab 

Use the General Options > General tab to set options that control the user interface (UI) and 
the operation and behavior of the software during data acquisition. In the descriptions 
below, references to “user activity” represents such activities as moving the mouse, moving a 
data or plot window, refreshing the screen, or clicking buttons in the application. 
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Field Name Description 

Keep real-time plot 
windows inside 
application window 

Prevents any open real-time plot windows from being moved outside the 
main kSA SpectR application window. 

Keep static plot 
windows inside 
application window 

Prevents any open analysis plot windows from being moved outside the 
main application window. 

Resolve RTC Y Axis 
Label Placement 

Centers Y-axis labels on plots. 
This is checked by default, and in general, you should not change it. 

Ensure GUI response 
during acquisition 

Enables the software to immediately respond to user activity during data 
acquisition.  
Unless you need absolute timing precision, this box should be checked. 
To ensure maximum data throughput during acquisition, clear this box. 

Set application to high 
priority during 
acquisition 

Gives the kSA SpectR software the highest priority, in terms of processing 
resources, if other applications are running on the kSA SpectR computer 
during data acquisition. This ensures that only real-time events are 
executed before the kSA SpectR task. 
Generally, you do not need to check this box. 

Optimize UI during 
acquisition  

Gives user activity lower priority during data acquisition. This will lead to 
fewer data interruptions, as these activities can reduce performance 
during acquisition. 

Lock UI during 
acquisition 

Ignores any user activity during data acquisition. 

Add auto saved 
documents to MRU list 

If you check this box and the Auto-save documents box on the Advanced 
Acquisition Options > Document Generation tab , the application 
includes the auto-saved documents to the MRU list. 

Save RTC data specific 
prefs 

If you change the X and/or Y ranges for a real-time chart (using the Set X 
Max/Min or Set Y Max/Min commands on the right-click menu in the RTC 
window), they will default back to the original values when you close the 
chart window. 
Check this box to keep those settings the next time the RTC is opened for 
any applicable data acquisition mode. 

Keep RTCs in view If you resize the main application window, some of the open RTCs might 
move outside the window frame.  
Check this box to automatically move RTCs to the center of the main 
application window any time it is resized. 

Save surface chart data 
specific prefs 

Synchronizes the look and feel (colors, etc.) of 3-D analysis plots for 
images. 

Save settings at 
program exit 

Saves the current kSA SpectR settings when you exit the application. You 
can save these settings manually by choosing Options > Save Settings. 
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Field Name Description 

Process data in 
background 

Processes data in the background when processor power is available. 
This helps to reduce the amount of processor power required to run the 
data acquisition. k-Space recommends that you always check this box. 
If this box is cleared, the acquisition could potentially be interrupted. 
You cannot change this setting when a data acquisition window is open. 
If the box is grayed out, close the current acquisition window. 
Check the Improve response with idle processing box to improve overall 
system responsiveness. 

CPU Affinity CPU used for processing. 

System ID This field defaults to the computer name, but you can change it if 
needed. 

Default compression Select None for no compression or ZLib to compress the data using the 
zlib lossless data format. Note that compression uses system resources 
that may affect performance during data acquisition. 

Default acquire mode Automatically opens a data acquisition window and any previously 
opened RTCs when you open the application. Select the preferred data 
acquisition mode and then check either or both of the following. 
 Start Automatically: Starts data acquisition using the default 

acquisition mode as soon as the software opens. 
 Minimize After Start: Reduces the acquisition window size to display 

as a banner when the software opens. 

 

When the acquisition window is minimized, you can click the  

button to restore the window to full size or the  button to close it. 
 Note: This option applies to the automatic acquisition at startup 

only. The application will not automatically minimize the acquisition 
window for subsequent acquisitions. 

Images and Video tab 

Use the General Options > Images and Video tab to specify options for kSA SpectR image and 
video files. 
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Field Name Description 

Keep Live Video 
window(s) inside 
application window 

Prevents the Live Video window from being moved outside the main kSA 
SpectR application window. 

Show pixel intensities 
as percentage 

The application displays the intensity for the current position of the 
cursor in the status bar at the bottom of the image or video window. 
Check this box to display the intensity as a percentage of the maximum 
possible intensity. 

 
If you clear this box, the application will display intensity as the value of 
the raw signal count. 

 
Scale pixel values  Scales the acquired data to use a length unit of measure (inches, cm, 

etc.) instead of pixels.  
Enter the pixel value by which to scale the data in the 1 Pixel equals field, 
and then select the unit of measure for the pixel equivalent. 

Default image 
compression 

To use image compression, select ZLib, which is a lossless data format 
that can be used across platforms. To disable image compression, select 
None. 

Logging tab 

Use the General Options > Logging tab to configure data and activity logging, as described in 
the Data and Activity Logging section. When logging is enabled, the application records 
details for all activity that occurs while the application is running. Logs are useful, both for 
recording software activity and for capturing the causes of errors, if any occur. 
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Field Name Description 

Category Select each applicable category, in turn, to specify logging settings for 
that category. You can specify different settings for each category. 

 
Allow/Allow by default Level of logging to allow for the selected category. 

 None: Does not log any data or activity . 
 All: Logs all system information. 
 High: Logs high-level details, such as start/stop times, data 

acquisitions, system information, and program errors. 
 Medium: Logs the same details as High, plus any application 

warnings. 
 Low: Logs the same details as Medium, plus any applicable notes. 
 Default: (for Allow field only) Uses the logging level selected in the 

Allow by default field. 

Save Saves the current settings for the selected category. 

Load Loads the settings from a saved logging preferences (.log) file. 

Delete Saved Deletes all saved logging preferences files. 

Reset Resets all logging levels for all categories to Medium. 

Log File Displays the name and complete path for the current log file. 

View Opens the current log text file in Microsoft Notepad, where you can view 
the logged information. 
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Appendix B: Input/Output Device Options 
The kSA SpectR system includes a number of analog and digital input and output boards that 
provide specific functionality, such as analog and digital input/output, counter/timer 
functions, etc. These capabilities are enabled by your Sentinel key. 

The Input/Output Device Options dialog includes several tabbed pages for configuring the 
analog and digital boards installed in your kSA SpectR system. Only the tabs that are most 
relevant to the kSA SpectR are discussed below. For information on any tabs or settings not 
mentioned here, please contact k-Space. 

 To access the Input/Output Device Options dialog, select Options > Input/Output Devices. 

The kSA SpectR system includes user-assignable analog and digital I/O, accessible using the 
Generic I/O 15 pin “D” connector on the back of the rack. You can select the board models 
and corresponding options in the Input/Output Device Options dialog.  
 

 Note 

See section 3 of the kSA SpectR Software Installation Guide for more details. 

 

Rotation Monitor tab 

The kSA SpectR system allows data acquisition to be synchronized with the rotation of the 
samples using a home pulse provided by the reactor. Use the Input/Output Device Options > 
Rotation Monitor tab to configure settings for that board. 
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Field Name Description 

Enable Rotation 
Monitor 

Enables the system to synchronize data acquisition with the rotation of 
the samples using a reactor home pulse. 

In pulse rising edge Check this box if the input pulse is active high (i.e., rising edge). If the 
input pulse is active low (i.e., falling edge), clear this box. 

Out pulse rising edge Check this box if the output pulse is active high (i.e., rising edge). If the 
output pulse is active low (i.e., falling edge), clear this box. 

Rotation Positions Number of rotation positions (maximum of 250). The application divides 
each rotation period evenly into this number of positions. Note that the 
total acquisition time (i.e., spectrometer integration time multiplied by 
number of positions, plus processing time) must be less than the rotation 
period. 

Stability threshold Maximum variation allowed in the rotation rate (default is 2%). If the 
acquisition exceeds this value, an error condition occurs, and the system 
pauses data acquisition until the rotation rate becomes sufficiently stable 
again. 

Max RPM Maximum rotation rate anticipated for the run. 
The application uses this value, in combination with the Duration setting 
in the acquisition window, to determine the total number of rotations to 
measure. The acquisition will run until this estimated number of 
rotations has been observed, or until the specified amount of time has 
elapsed, whichever comes first. So, to prevent the acquisition from 
timing out early, set the Max RPM value to the maximum rotation rate 
anticipated during the run. If in doubt, choose a large number. 

In pulse timeout Maximum time to allow between the input pulses before an error 
condition occurs and the data acquisition is halted. 
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Field Name Description 

Gear Ratio If your system does not have a rotation ratio that is 1:1, use these fields 
to specify the ratio between the outer gear (the one that measures the 
rotation rate) and the inner gear (the one tied to the sample rotation). 

Port Number of the port that corresponds to the rotation controller. This is 
listed in the Windows Device Manager as USB Serial Device (COM x), 
where x represents the port number. 

 

Spectrometers tab 

The kSA SpectR system supports the use of multiple spectrometers. Use the Input/Output 
Device Options > Spectrometers tab to enable the applicable spectrometers. 

 

Field Name Description 

Device  The application assigns an ID number to each available spectrometer and 
displays that ID in this column. 

Serial Number The application also reads the manufacturer’s serial number for the 
spectrometer and displays that information in this column. 

Reference Tolerance This tolerance value dictates how closely the wavelength range of a 
reference spectrum must match the current spectrometer range (default 
is 0.2 nm). 
For example, if a spectrometer is re-calibrated and the wavelength shifts 
by more than this amount, you cannot use previously acquired 
references. 

Enable  You must check this box for the spectrometers that you will use. The 
application lists all enabled spectrometers on the View menu. 
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Appendix C: Spectrometer Properties 
To adjust the settings for the spectrometer, right-click the Live Spectrometer window and 
select Properties to open the Spectrometer Properties dialog. This dialog includes several 
tabbed pages, each with different parameters and options that apply to the selected 
spectrometer. Only the tabs that are most relevant to the kSA SpectR are discussed below. 
For information on any tabs or settings not mentioned here, please contact k-Space. 

Averaging tab 

Use the Spectrometer Properties > Averaging tab to specify the number of frames from 
multiple spectra to average together before performing any analysis to reduce the effects of 
random noise. Note that this is different from sampling, in which the analysis is performed on 
each of the spectra separately, and then the results are averaged together. 

 

In the Range field, select the applicable range to set the scale for the Average slider, and then 
use the slider to specify the number of frames to average together to generate a spectrum. 

 Short: 1 – 100 
 Medium: 1 – 1,000 
 Long: 1 – 20,000 

Rotation Monitor tab 

Use the Spectrometer Properties > Rotation Monitor tab to specify the number of rotation 
positions to track across the rotating platen to monitor rotation. This determines the 
resolution of the rotation monitor; i.e., for 100 positions, there is a position every 3.6 degrees 
on the platen. 
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Spectrometer tab 

Use the Spectrometer Properties > Spectrometer tab to specify data acquisition options for 
the selected spectrometer. 

 

Field Name Description 

Subtract Hardware 
Background 

If a dark background file is available for the selected spectrometer, this 
box will automatically be checked. 
Dark background data are spectra that represent the inherent 
background noise due to thermally generated charge carriers. To provide 
the cleanest spectra for analysis, the application subtracts these spectra 
from the measured spectra, leaving only the noise-free spectra. 

Integration Time Length of time for the spectrometer to collect a signal before it digitizes 
and reads the signal. Use the integration time to decrease (low values) or 
increase (high values) the intensity. 
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Field Name Description 

Flat Field Correction This checkbox should be cleared, as the kSA SpectR does not use FFC. 

External trigger Acquires data only when the spectrometer trigger input line senses a 
signal (depends on the current acquisition mode). 

High Gain Places the spectrometer in high-gain mode, in which the gain is 
increased 20x. This facilitates the detection of weaker signals. However, 
it also results in higher noise, so the signal-to-noise (S/N) ratio can be 
compromised. It is generally only recommended for spectrometer’s 
containing a cooled sensor, as this serves to significantly reduce the 
noise. 

Bin All Rows Combines the corresponding pixels in the individual columns in a 2-
dimensional sensor array, effectively creating a single row of pixels. This 
feature only applies to visible spectrometers and should always be 
enabled when using such spectrometers. 

Read Device 
Temperatures 

Reads the real-time temperature of the rack (i.e., internal PCB) and 
sensor and displays these values in the status bar of the Live 
Spectrometer window. 

Wavelength Filter tab 

Use the Spectrometer Properties > Wavelength Filter tab to filter out a portion of the 
spectrum. This can be beneficial for systems that incorporate a laser for curvature, and/or 
reflectivity measurements. To enable the filter, check the Remove and Interpolate box, and 
then specify the range of wavelengths to remove. 

In the example shown below, to avoid the intense reflections from a 405 nm laser, the 
application removes wavelengths between 395 and 415 nm and replaces them with 
interpolated data. 
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Appendix D: Spectrometer Configuration 
Options 

In the Single-wafer Spectral Reflectivity Acquisition window, the Spectral Reflectivity field 
includes an associated Configuration Options dialog, where you can specify options for the 
selected spectral reflectivity source. The dialog contains numerous options for configuring 
the source for the current data acquisition. Be sure to verify and adjust these options before 
you start the data acquisition. 

Only the tabs that are most relevant to the kSA SpectR are discussed below. For information 
on any tabs or settings not mentioned here, please contact k-Space. 

 To access the Spectrometer Configuration Options dialog, click the Config button in the 
Single-wafer Spectral Reflectivity Acquisition window. 

Extrema Finder tab 

Use the Spectrometer Configuration > Extrema Finder tab to configure the settings used to 
find the extrema and/or passband edges in the Real-time Fabry-Perot chart. (See How to 
Acquire Spectral Reflectivity Data for more details.) 

This can be accomplished by applying a low-pass digital smoothing filter using the Savitzky-
Golay moving window least-squares polynomial fitting method. This can smooth noisy data 
without loss of resolution, provided that the filter width is not too much wider than the 
FWHM of the features in the data. Because the data are fitted using polynomials, it is trivial 
to calculate the derivatives (up to the order of the smoothing polynomial). 

This feature can find extrema (such as the Fabry-Perot Dip) by finding the zeroes in the first 
derivative. To be considered valid, extrema candidates must fall within the specified 
wavelength range, and meet the minimum curvature and minimum slope criteria specified on 
this tab.  

This feature can also find the passband edges by finding the peaks in the first derivative (i.e., 
inflection points). To increase the precision of the results, the data are interpolated to the 
desired wavelength resolution. Note that there are independent settings for finding the left 
and right passband edges. 
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Field Name Description 

Enable wavelength 
range 

Rejects any extrema candidates outside the range defined by the Min. wl 
and Max. wl fields. 

Smoothing Uses a local least-squares polynomial to approximate the data within a 
moving window. 
 Poly order: Order of the polynomial for the filter. 
 Width: Total width of the smoothing window (must be an odd value). 

Test criteria  Min. pts: Minimum number of consecutive rising or falling points that 
must precede the candidate in question. 

 Min. Curve: Minimum absolute value required for the candidate’s 
curvature (i.e., second derivative). 

 Choose the candidates to allow. 
 Allow all: Allows all candidates, regardless of the number of 

points or slope value. 
 Require leading / Require leading and traling: Requires at least 

the number of points specified in the Min pts field with a slope 
for which the absolute value meets or exceeds the Min. Slope. 

Enable quadratic fit Performs a least-squares quadratic fit in the vicinity of an extremum to 
refine its wavelength value. The value in the Width field defines the 
range of data points to fit on either side of the extremum. 

Enable passband 
detection 

Enables the finding of the passband edges. Note that there are 
independent settings for the left and right edges. 

Min. wl. Minimum wavelength for an inflection point candidate. 

Max. wl. Maximum wavelength for an inflection point candidate. 

Resolution (nm) Wavelength resolution to be used for interpolating the data. 

Poly order Order of the polynomial for the smoothing filter. 

Width Total width of the smoothing window (must be an odd value). 
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Field Name Description 

Log intermediate 
results  

Generates a log file containing diagnostic information. 

Range Matching tab 

Use theSpectrometer Configuration > Range Matching tab to enable smoothing, and to 
interpolate the spectra to a common set of wavelength values.  

The Enable smoothing option applies a low-pass digital smoothing filter using the Savitzky-
Golay moving window least-squares polynomial fitting method. This can smooth noisy data 
without loss of resolution, provided that the filter width is not too much wider than the 
FWHM of the features in the data. 

The Enable common wavelengths option interpolates the spectra to a common set of 
wavelength values defined by the Min, Max, and Interval values. This allows the data to be 
properly scaled using an Absolute reflectivity file specified in the Reference tab. 
 

 Note 

The Enable common wavelengths options must be enabled to obtain a valid reflectivity value.  
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Field Name Description 

Enable smoothing Applies a low-pass digital smoothing filter to the spectra before analysis, 
and then click the Configure button to specify the following parameters. 
 Derivative number: Derivative number (0 for smoothing only). 
 Boxcar Width: Total width of the smoothing window (must be an odd 

number of data points). 
 Smooth Order: Order of the least-squares polynomial used to 

approximate the data within the moving window.Typical values are 2 
or 4. 

 Extend Data: Choose the applicable option for extending data beyond 
the ends of the spectrum. 
 0: Excludes data points near the ends of the spectrum from 

smoothing, as there is an insufficient number of neighboring 
points to fill the window. 

 1: Repeats the data at the ends of the spectrum as needed so that 
the smoothing window can be applied across the entire spectrum. 

Typically, option 1 is chosen. 

Enable common 
wavelengths 

Check this box to interpolate the spectra to a common set of wavelength 
values defined by the Min, Max, and Interval fields. 

Reference tab 

Use the Spectrometer Configuration > Reference tab to choose data to use as a reference 
spectrum to normalize the measured spectral reflectivity to that of a bare substrate.  
 

 Note 

If you checked the Auto-select reference box in the Reference (Single Wafer) Acquisition window 
when the reference data were acquired, that reference file should already be loaded. 

 

Field Name Description 

Reference Choose the desired reference option. 
 No Reference: The application will not normalize the spectral data. 
 From File: The application uses the data contained in the selected 

.bsrf reference file. 
 From Source: This option is not available. 
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Field Name Description 

Reflectivity calibration In the Absolute reflectivity file field, select a calibration file that 
corresponds to the selected reference spectrum. This .csv file should 
represent the absolute reflectivity (0-1) of the substrate. The application 
uses the data to convert the measured reflectivity of the reference to an 
absolute scale. 
The wavelength range must encompass the spectrometer range. If you 
checked the Enable common wavelengths box on the Range Matching 
tab, the application will interpolate data to a common set of wavelength 
values, so the range and spacing need not match exactly. 

Reflectivity tab 

Use the Spectrometer Configuration > Reflectivity tab to enable the reflectivity calculation 
and fitting and to specify growth and fitting parameters. 

During film growth, the reflectivity at a given wavelength λ oscillates with a period equal to 
λ/2nG, where G is the growth rate. The kSA SpectR system can exploit this to determine the 
growth rate, layer thickness, and optical constants (n, k) from the measured reflectivity of a 
multi-layer structure in real-time using a sophisticated Virtual Interface algorithm originally 
developed at Sandia National Laboratories, as described in the How to Perform a Reflectivity 
Fit section. 
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Field Name Description 

Enable Reflectivity Enables the reflectivity algorithm and uses the parameters below. 

Enable fit Enables data fitting during acquisition. 

Recipe Displays the name of the selected reflectivity recipe (.rrp) file. 
 Load: Loads and applies settings from a saved recipe file. 
 Save: Saves the current settings in a recipe file. 

Growth Parameters Estimates for the applicable growth parameters. As with any fitting 
algorithm, the better the estimate of the fitting parameters, the faster 
the convergence. 

 Note: You must choose either the Lock n, k option or the Lock s 
option. 
 n: Index of refraction of the deposited material. If this value is 

unknown, enter 1 (i.e., vacuum) 
 k: Extinction coefficient (i.e., imaginary part of the complex index of 

refraction) of the deposited material. If unknown, enter 0 (i.e., no 
absorption). 

 G: Estimated growth rate (in nm/s). If unknown, enter 0. 
 Min/Max G: Range of valid growth rate values. 
 s: Reflectivity scale factor for the fit, intended to account for such 

things as absorption from a coated viewport or reflectivity calibration 
errors. This parameter relates the measured reflectivity values to the 
absolute reflectivity via 𝑹𝑹𝒎𝒎𝒎𝒎𝒎𝒎𝒎𝒎 = 𝒔𝒔 ∙ 𝑹𝑹𝒇𝒇𝒇𝒇𝒇𝒇. You can adjust this, unless 
n and k are locked at specific values, in which case the best-fit value 
of s is calculated. 

 Reflectivity Table: Opens the Reflectivity Properties dialog, where you 
can view n and k values for selected materials. Click the Reflectivity 
Table button again to close the dialog. 

Laser Settings  Lambda: light source’s wavelength value. 
 Angle: Angle of incidence of the incoming light source beam, with 

respect to the normal to the surface. 
 Polarization: Choose the applicable polarization type.  
 p: The polarization vector is parallel to the plane of incidence and 

reflection. 
 s: The polarization vector is perpendicular to the plane of 

incidence and reflection (from the German senkrecht). 

 Note: In the case of normal incidence (i.e., 0°), the choice of 
polarization is immaterial, as there is no distinction between the two 
polarization types. 
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Field Name Description 

Fit Processing 
Parameters 

These parameters regulate the fit updates and allow the fit region to 
move along with the data (i.e., at any particular time, the fit can include 
all acquired data, or a limited range of data points). 
 Fit every: Data point interval at which to perform a reflectivity fit. 

Fitting uses a significant amount of computer resources and can slow 
the acquisition, especially for large data sets. (10 is a typical value.) 

 Ignore data: Length of time to wait before starting to fit data 
acquired from that point on. This helps with deposition processes 
with too little data at the beginning to provide a good fit. 

 Delay fit: Length of time to wait before starting to fit all the acquired 
data, including those acquired during the delay. 

 Fit Errors Allowed: Number of consecutive fitting errors allowed 
before the application stops fitting data.  

Example: If you allow 1 fit error and the algorithm detects an error, 
it assumes good fit values and continues fitting based on the last 
good fit. If an error occurs when fitting the next set of data points, it 
sets the fit to 0 and stops fitting. 

 Scale factor for RMS noise filter: The cutoff for a low-pass RMS noise 
filter (default 0.8). A lower cutoff value rejects more data, whereas a 
higher value allows noisier data to be included in the fit 

 Max Fit Iterations: Maximum number of attempts to fit the data. 
 Allow zero fit result: Accepts fit values of 0 (no fit). 
 Fit Region: Allows the system to fit to the latest subset of the total 

data. This is recommended if the deposition rate will vary because 
the fit normally takes into account all of the data, and changes in 
deposition rates will result in a failure to fit those changes correctly. 
 Region width: Total number of seconds of data that will be put 

into the fitting algorithm. 
 Region increment: Rate at which the window of data slides along with 

the data. I.e., for an increment of 10, the application will drop 10 data 
points after the Region width has passed. 

Signal Parameters  Use Modulation: (N/A for the kSA SpectR) 
 Scale factor: The application calculates and enters this value through 

a Reflectivity Calibration acquisition. It is the ratio of the reflectivity 
to the raw signal. 

 Offset: Intensity value (positive value) to subtract from the signal to 
account for ambient light.  

Smoothing Smoothing method and smoothing factor to use. 

Spectral Reflectivity Configuration tab 

Use the Spectrometer Configuration > Spectral Reflectivity Configuration tab to specify the 
minimum value of the peak intensity that a spectrum must possess to be considered valid, to 
enable the application to create scan images from the acquired data, and to enable a digital 
input signal to trigger a Fabry-Perot extrema measurement. 
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Field Name Description 

Processing intensity 
floor 

The minimum value of the peak intensity that a spectrum must possess 
to be considered valid. The application ignores spectra with peak 
intensities below this value. 

Create scan images Check this box to create montage plots. If using multi-wafer mode, it will 
create a separate plot for each active satellite. 
Check the Save all data to image box to save all the valid spectra from 
each rotation. If this box is cleared, the application will save only the first 
valid spectrum from each rotation. 

Find spectral extrema 
when triggered 

Check this box to use a digital input signal on the selected I/O channel to 
trigger the Fabry-Perot extrema measurement. Select the type of input 
pulse that will trigger the measurement — active high (i.e., rising edge) 
or active low (i.e., falling edge). 
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Appendix E: Advanced Acquisition Options 
Each acquisition mode includes an associated Advanced Acquisition Options dialog, where 
you can specify parameters for that acquisition mode. The Advanced Acquisition Options 
dialog contains several tabbed pages with various options. The tabs that are available depend 
on the selected acquisition mode. Only the tabs that are most relevant to the kSA SpectR are 
discussed below. For information on any tabs or settings not mentioned here, please contact 
k-Space. 

 To access the Advanced Acquisition Options dialog, click the Advanced button in the 
selected data acquisition window. 

Advanced Settings tab 

Use the Advanced Acquisition Options > Advanced Settings tab to specify parameters for 
determining the center wavelength of the selected spectral lines and calculating a 
spectrometer offset based on the published wavelength values. 

http://physics.nist.gov/PhysRefData/Handbook/element_name.htm
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Field Name Description 

Select Spectral Lines Check the box for one or more spectral lines to use to determine the 
spectrometer offset. 

Fitting Parameters  Smoothing Width: Total number of points to use for the digital boxcar 
smoothing filter. 

 Order of Smoothing Poly: Smoothing polynomial order (0 for boxcar). 
 Min pts: Minimum number of consecutive data points required for 

slopes of the same sign (increasing or decreasing) to be considered a 
valid peak. This will reject any spurious noise spikes. 

 Min curvature: Minimum curvature (i.e., second derivative value) 
required to be considered a valid peak. This will reject small peaks. 

 Linfit Pts: Number of points to use in the linear fit. For example, if you 
enter 7, the application fits the 7 neighboring data points on either side 
of the data point closest to the zero crossing in the 1st derivative. 

 Peak Search Radius: Radius of the peak search window. For example, if 
you enter 3, the application will reject any peaks that are more than 3nm 
from the target wavelength. 

Wavelength 
Correction Type 

 Constant Offset: Uses the Spectrometer Setup Parameters to correct the 
wavelength by a constant amount. These parameters are specific to the 
selected spectrometer. 
 Xstart: Starting wavelength in nm. 
 wtc_ShiftNm: Overall wavelength shift (in nm) to apply, relative to 

original factory settings. 
 Linear Offset: This option is not currently available for the kSA SpectR. 
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Field Name Description 

Lower/Upper limit Range of wavelength shifts (in nm) to allow. 

Delay tab 

Use the Advanced Acquisition Options > Delay tab to add a delay between data points to limit 
the file size or to provide a constant time interval, even if the spectrometer integration time 
can vary. 

There are three different types of delays available, and each type is independent of the 
others, so be sure to set up all three, if desired. 

 

Field Name Description 

Delay type Select each delay type, in turn, and then specify options for the selected 
delay type. 
 Between data points: Delays acquisition between each data point 

acquired. 
 Before first data point: Delays acquisition before the first data point is 

acquired. 
 Between samples: Delays acquisition between each sample of 

acquired data. (Specify the number of samples per data point on the 
General tab of the Advanced Acquisition Options dialog.) 
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Field Name Description 

Delay Choose the applicable delay option for the selected delay type. 
 No delay: Prevents any delay for the selected delay type during 

acquisition. To have no delays of any kind during the acquisition, 
select No delay for all 3 delay types. 

 Constant: Uses the specified delay for all delays of this type. 
This is similar to skipping frames, but it is more exact because frame 
skipping depends on computer speed, which changes from computer 
to computer and can change during acquisition. 

 Exponential: Samples the data in time intervals that follow the 
dependent value of an exponential curve — slowly at first and then 
faster and faster — using the constants you enter for k and a. 
This is helpful for processes in which the most important part 
happens at the end of the process. Note that the a parameter must 
be a positive number. 

 Logarithmic: Samples the data in time intervals that follow the 
dependent value of a logarithmic curve — quickly at first and then 
slower and slower — using the constants you enter for k and a. 
This is helpful for processes in which the most important part 
happens at the beginning of the process. 

 Synchronize Shutter with delay: Synchronizes the shutter motion 
with the delay. The total delay is the length of delay specified above 
plus the shutter response time. You must set the shutter control and 
response time on the Chamber Control tab of the Input/Output 
Device Options dialog. 

 Example: if the delay type is Between data points, the kSA SpectR will 
open/close the shutter for each data point. The delay is needed because 
the mechanical shutters take time to open (typically about 2s), and the 
shutter must be fully open for the kSA SpectR to capture the data. 

Display live data during 
delay 

Keeps the image in the video window live. If you clear the box, the last 
sample remains in the Live window until the next sample is acquired. 

Document Generation tab 

Use the Advanced Acquisition Options > Document Generation tab to define how the 
application names and saves documents generated during data acquisition. 
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Field Name Description 

Store Incrementally Saves data in small groups instead of waiting until the system RAM is full. 
k-Space recommends that you enable this feature for longer data 
acquisitions (longer than 5 minutes). 
When you check this box, the application automatically checks and 
disables the Auto-open documents, Auto-save documents, Auto-close 
documents, and Auto-hide documents boxes. 

Auto-save documents Automatically saves acquired data to both RAM and disk. 

Auto-close documents (Available only when the Auto-save documents checkbox is checked) 
Automatically closes the acquired data file as soon as data acquisition is 
complete. 

Auto-hide documents (Available only when the Auto-close documents checkbox is checked) 
Briefly flashes the data on the screen while it is being saved. This mostly 
serves as a visual aid to remind you that the document has been saved 
and closed. 

Auto-export data Saves all acquired data to both a .kdt file and to one of the following. 
 All data to text: Exports all acquired data to ASCII .txt files. 
 Custom using: Exports only the data specified in the selected custom 

export recipe file (.exprt). Click the Browse for recipe button to select 
the applicable export recipe file. 

 Note: Enabling this option may result in very large files that take 
considerable time to save. In general, it is a good idea to store data in the 
native .kdt format and then, if needed, export the data after acquisition. 
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Field Name Description 

File name format (This is the unlabeled drop-down list below the Auto Export fields.) Select 
the format to use when naming the data acquisition files. 
 Manual run name: Requires you to enter a file name for each data 

acquisition. 
 Auto-incrementing run name: Uses the name in the Base run name 

field, appends a number to the end of the base name, and 
increments it by 1 (up to 9999) for each new acquisition. 

Example: For a base run name of Run, the first acquired file will be 
Run0001, the second will be Run0002, the third will be Run0003, etc.  

 To start the count at 0000, check the Zero run box. 
 Date/time-based run name: Uses the name specified in the Base run 

name field and appends the computer’s date/time stamp to the end 
of the file name for each new acquisition. 

Example: For a base run name of Run and a file generated at 
1:59:40 p.m. on June 19, 2021, the file name will be 
Run20210619.135940, where 20210619 represents the date in 
YYYYMMDD format and 135940 represents the time in HHMMSS. 

 Base Name Only: Uses the name specified in the Base run name field 
for every new acquisition. The software will prompt you to confirm 
that you want to replace it after each acquisition. 

I/O Settings tab 

Use the Advanced Acquisition Options > I/O Settings tab to select various input and output 
options. 
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Field Name Description 

Additional I/O Choose the applicable option for handling thermocouple data. 
 No thermocouple: Ignores and discards thermocouple data without 

saving them. 
 Read thermocouple (serial): Reads the thermocouple value as a serial 

input. This setting depends on the port. For information on the data 
format, contact k-Space. 

 Read thermocouple (analog): Reads the thermocouple value as an 
analog (i.e., voltage) input. 

Display live spectra on 
open 

Opens the Live Spectrometer window automatically each time you open 
an acquisition window. 
You can check the Open Minimized box to automatically minimize the 
spectra window when it opens, so that only the title bar is visible. 

 
When the window is minimized, click the  button to expand it. 

Display Light Source 
Control on Open 

Opens the Light Source Control window automatically each time the 
application opens. 

Display temperature on 
rack LCD 

Simultaneously updates the data on the rack display and on the 
application interface on the computer. 

Turn on Light Source at 
start of run 

Automatically turns the broadband light source on when you click the 
Start button in the acquisition window. 

Turn off Light Source at 
end of run 

Automatically turns the broadband light source off when you click the 
Stop button in the acquisition window. 

Reflectivity Shutter and Light Configuration tab 

Use the Advanced Acquisition Options > Reflectivity Shutter and Light Configuration tab to 
enable the reflectivity shutter and light source control.  

 

Field Name Description 

Use reflectivity shutter Check this box to enable the broadband light source’s integrated shutter. 
Note that the shutter is controlled by digital output channel 0 on the I/O 
board. 

Enable light control Check this box to control the broadband light source remotely with the 

 button on the toolbar. 
In the Channel field, select the digital output channel used to control this 
feature (Default is 3) 
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 Note 

If using the light source’s integrated shutter, one of the following 3 conditions must be met to 
prevent the shutter from attempting to open and close too quickly: 
 the spectrometers must be externally triggered 
 the acquisition delay time must be at least 2.0 seconds 
 the integration time of the spectrometer(s) must be at least 2.0 seconds  
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Appendix F: Image and Plot Properties 
Every image and data plot window includes in the kSA SpectR application has an associated 
Properties dialog that is comprised of several tabbed pages with options that affect the way 
the data are displayed. 

For Scan mode image windows, you can view information about the image — image type, 
date it was acquired, exposure time, etc. — in the associated Image Properties dialog. You 
can also add comments about the image for future reference. 

For .kdt data plot windows, you can select the data to display for the X and Y axes, change the 
colors, fonts, and labels for the plot window and plotted data, and apply filters to the data. 
You can also view the settings selected for reflectivity, reference file, extrema finder, and 
more in the associated Plot Properties dialog. 

Image Properties 
Most of the fields in this dialog are for informational purposes only, so they are grayed out 
and cannot be modified. However, you can add or update comments and apply a color 
palette to the display. 

 To access the Image Properties dialog, right-click a Scan mode image window and select 
Properties. 

General tab 

The Image Properties > General tab displays the settings that were used to capture the 
selected image and other general information. These fields are read-only and cannot be 
modified. 
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Field Name Description 

File name Name of the selected image or movie file. 

Image type Image type (single image, movie frame, or line scan) for the selected 
image or movie. 

Acquisition settings Parameter settings that were in effect when the selected image or movie 
was acquired. 
 Exposure Time: Length of exposure used. 
 Average: Number of frames of data that were summed together for 

each data point. 
 Background Subtraction: Background subtraction setting used. 
 Tracking: Tracking type used during the acquisition to monitor areas 

with high intensity. 
 Delay: Time delay that was used between data points. 

Image properties Dimensions, color mode (based on the method and camera that were 
used to generate the image), bit depth, and compression type. 

 Note: Bit depth usually depends on the physical characteristics of the 
camera. For example, with a bit depth of 8, the maximum number of 
grayscale intensities (black to white) or colors is 28 or 256. 

Time Date and time the image or movie was captured and the length of time 
(including pauses) it took to record the image or movie. 

Palette tab 

Use the Image Properties > Palette tab to colorize the selected image or movie. Note that this 
feature changes the way the image is displayed only; it does not alter the original image. 
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Field Name Description 

Palette Select the preferred color scheme. There is an extensive list of palettes to 
choose from. Note that the Green scale palette most closely simulates 
the RHEED screen colors. 

Mapping Select the preferred level of data to map to the selected camera. 
 Normal: Displays the data in its original format. 
 Eight Most Significant Bits: Keeps only the most significant 8 bits that 

comprise the image. This reduces the number of shades to a value 
that is visible to the human eye. 

 Maximized: Displays the data scaled over 8 bits, or 256 levels, so that 
the brightest part of the image is white, and the darkest part is black. 

Scan Mode tab 

The Image Properties > Scan Mode tab displays information about the selected Scan Mode 
image. These fields are read-only and cannot be modified. 

 

Field Name Description 

Num data points Number of data points collected. 

Number of samples per 
data point 

Number of measurements taken for each data point. 

Regions captured (N/A for the kSA SpectR) 

Plot Properties 
The kSA SpectR application displays data for both RTCs and post-acquisition analysis plots in 
plot windows. Each plot window has an associated Plot Properties dialog, where you can 
modify the available parameters to change the way the data are displayed. 

The Plot Properties dialog is also available for acquired data (.kdt and .bsrf) files. 
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Colors tab 

Use the Plot Properties > Colors tab to select colors for the various elements in the plot 
window. The elements available on this tab vary based on the selected plot type. 

 

Data tab 

Use the Plot Properties > Data tab to specify the number of columns to plot and to select the 
data to plot for those columns. 
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Field Name Description 

# of data columns / 
N Data Columns 

Number of columns of data to plot. If you select 2 or more columns, you 
can specify display options for the Y axis. 

Data Columns The items in this drop-down list corresponds with the number selected in 
the # of data columns/N Data Columns field (i.e., if you select 3, the 
drop-down list includes Data column 1, Data column 2, Data column 3). 
Select each data column, in turn, and then in the Data field for the Y axis 
and X axis sections, select the type of data to plot for that column. 

Where Filters the plotted data by the selected data type. 
 All: Plots the entire range of data. If there is a large amount of data, it 

may take several minutes to generate the plot. 
 Is: Plots a specific spectrum based on the data type selected. In the 

corresponding field, enter the data value to plot. 
 From: Plots a specific range of data. In the corresponding fields, enter 

the lower and upper limit of the range to plot. 

Additional Column to 
View 

(Optional) Additional data type to display with the other title information 
along the top. 
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Field Name Description 

Apply changes to all 
open plots of same type 

Applies any changes made on this tab to all open computed data plots. 

Sync charts that contain 
the same customer 
device ID 

Applies these settings to all plots generated for the current kSA SpectR 
system. 

Independent x-axes Uses different X axis data for each column. When this box is clear, the 
application plots the same X axis data against the different Y axes data. 

 

Y axis display options 

For some plots, when you select 2 columns in the # of data columns field on the Plot 
Properties > Data tab, the Independent y-axes box may be available, depending on the type 
of data. When you check this box, the application displays a separate Y axis for each column. 

 

In addition, the Plot Properties dialog will include a Y axis tab for each column, so that you 
can define the range and tickmark properties for each. Note that you must close and then 
reopen the Plot Properties dialog before the additional Y axis tabs will be available. 
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Reference tab 

The fields on the Plot Properties > Reference tab are read-only and reflects the option 
selected on the Spectrometer Configuration > Reference tab when the data were acquired 
for this kdt plot window. 

 If the No Reference option was selected, the File field displays None. 
 If the From File option was selected, the File field displays the name of the reference 

(.bsrf) file that was used. 

 

Series tab 

Use the Plot Properties > Series tab for images, platen scans, and plots with more than one 
series (or set) of data, to define parameters that will distinguish the sets from one another. 

 

Field Name Description 

Series Select each applicable series, in turn, to specify line and marker options 
for that series. You can specify options for up to 100 different series. 
To specify settings that will be used by multiple series, select [All Series], 
and then specify the applicable settings. You can then apply these 
settings to a specific series by selecting that series in the Series field and 
checking the Same as [All Series] box. The application will disable all 
other fields for that series and apply the settings you selected for [All 
Series]. 

Lines Line color and thickness (in pixels) for the selected series. 
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Field Name Description 

Markers Marker symbol to use for the selected series and attributes for the 
markers, including the size as a percentage of the original, the style (filled 
or outlined), and the colors for the fill and outline. 

Spectra Acquire Source 

Use the Plot Properties > Spectra Acquire Source tab to configure a .kdt data file to function 
as the data source, as if it were live spectrometer data. 

 

Field Name Description 

Loop Continues acquiring data from the beginning of the .kdt file when it 
reaches the end. 

This is different from the Loop  button on the kdt toolbar, which loops 
through the playback only, not the acquisition. 

Animate during acquire This box is checked by default and cannot be changed. It enables you to 
view the data in the .kdt file as it is played during acquisition. 

Acquisition Limits Defines the parameters that start and stop acquisition, based on the 
selected data type. The application trims data outside these bounds, 
enabling you to begin and end acquisition at any point. 

 Note: The increment values for the Start and Stop fields are based on 
the values in the .kdt file. 
 If you select Data Points, the values are sequential numbers. 
 If you select Elapsed Time, the values are the recorded time values. 
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Field Name Description 

Elapsed time Choose the preferred option for compressing the spectra over time. 
 From document data: Bases the elapsed time on the data selected 

here. Most kSA SpectR users select Elapsed Time, so that the elapsed 
times for the new .kdt acquisition and the source .kdt file match. 

 Generate at: Divides the data in the .kdt by the number specified 
here, resulting in the acquired data covering the specified number of 
data points per second. 

 Example: If the .kdt file contains 8,000 data points that were 
generated over 9,999 seconds, and the Generate at value is 1000, the 
new .kdt file will contain all 8,000 data points, compressed to a total 
elapsed time of 8sec (8000/1000). 

Acquisition speed Choose the preferred speed at which the spectra will be available for 
processing during a new acquisition. 
 Match elapsed time: Makes the data available for processing at the 

same speed at which it was originally acquired. 
 Acquire at: Makes the data available at the speed specified here. 

RT Input Use these fields to specify options for reprocessing data from a saved file 
as if it were real-time data. 
 Spectra: Spectra source 
 Temperature: (N/A for the kSA SpectR) 

Reference Tolerance Tolerance value that dictates how closely the wavelength range of a 
reference spectrum must match the current spectrometer range. 
For example, if a spectrometer is re-calibrated and the wavelength shifts 
by more than this amount, you cannot use previously acquired reference 
spectra. 
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